]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Modify Makefile.am for new file names
[empathy.git] / src / Makefile.am
index c7344c8c8ef55230f47c7fa4b7b6b27b874fe229..4b1541312e7ac3df189c88049a84fa84dd4ab332 100644 (file)
@@ -1,44 +1,86 @@
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
-       -DPREFIX="\"$(prefix)"\"                        \
-       -DSYSCONFDIR=\""$(sysconfdir)"\"                \
-       -DDATADIR=\""$(datadir)"\"                      \
-       -DLIBDIR=\""$(libdir)"\"                        \
-       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(EMPATHY_CFLAGS)                               \
+       $(LIBNOTIFY_CFLAGS)                             \
        $(WARN_CFLAGS)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
+       $(top_builddir)/extensions/libemp-extensions.la         \
+       $(LIBNOTIFY_LIBS)                                       \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
-       empathy-accounts
+       empathy-logs
 
-empathy_SOURCES = empathy.c
-empathy_accounts_SOURCES = empathy-accounts.c
+BUILT_SOURCES= \
+       empathy-tube-dispatch-enumtypes.h \
+       empathy-tube-dispatch-enumtypes.c
 
-# Dbus service file
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
+empathy_SOURCES =                                                      \
+       bacon-message-connection.c bacon-message-connection.h           \
+       empathy.c                                                       \
+       empathy-about-dialog.c empathy-about-dialog.h                   \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h             \
+       empathy-call-window.c empathy-call-window.h                     \
+       empathy-chatrooms-window.c empathy-chatrooms-window.h           \
+       empathy-chat-window.c empathy-chat-window.h                     \
+       empathy-event-manager.c empathy-event-manager.h                 \
+       empathy-ft-manager.c empathy-ft-manager.h                       \
+       empathy-import-dialog.c empathy-import-dialog.h                 \
+       empathy-import-pidgin.c empathy-import-pidgin.h                 \
+       empathy-main-window.c empathy-main-window.h                     \
+       empathy-misc.c empathy-misc.h                                   \
+       empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
+       empathy-preferences.c empathy-preferences.h                     \
+       empathy-sidebar.c empathy-sidebar.h                     \
+       empathy-status-icon.c empathy-status-icon.h                     \
+       empathy-tube-dispatch.c empathy-tube-dispatch.h                 \
+       ephy-spinner.c ephy-spinner.h
 
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
-       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+nodist_empathy_SOURCES = $(BUILT_SOURCES)
 
-chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
+empathy_logs_SOURCES = empathy-logs.c
 
-BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-accounts-dialog.ui              \
+       empathy-call-window.ui                  \
+       empathy-chatrooms-window.ui             \
+       empathy-chat-window.ui                  \
+       empathy-ft-manager.ui                   \
+       empathy-import-dialog.ui                \
+       empathy-main-window.ui                  \
+       empathy-new-chatroom-dialog.ui          \
+       empathy-preferences.ui                  \
+       empathy-status-icon.ui
 
-EXTRA_DIST =                                                   \
-       org.gnome.Empathy.Chat.service.in                       \
-       $(autostart_DATA)                                       \
-       $(chandler_DATA)
+dist_man_MANS =                        \
+       empathy.1
+
+# rules for making the glib enum objects
+%-enumtypes.h: %.h Makefile.in
+       glib-mkenums \
+       --fhead "#ifndef __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n#define __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
+       --fprod "/* enumerations from \"@filename@\" */\n" \
+       --vhead "GType @enum_name@_get_type (void);\n#define $(shell echo $* | tr [:lower:]- [:upper:]_ | sed 's/_.*//')_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n"         \
+       --ftail "G_END_DECLS\n\n#endif /* __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__ */" \
+       $< > $@
+
+%-enumtypes.c: %.h Makefile.in
+       glib-mkenums \
+       --fhead "#include <$*.h>\n#include <$*-enumtypes.h>" \
+       --fprod "\n/* enumerations from \"@filename@\" */" \
+       --vhead "GType\n@enum_name@_get_type (void)\n{\n  static GType etype = 0;\n  if (etype == 0) {\n    static const G@Type@Value values[] = {"     \
+       --vprod "      { @VALUENAME@, \"@VALUENAME@\", \"@VALUENAME@\" }," \
+       --vtail "      { 0, NULL, NULL }\n    };\n    etype = g_@type@_register_static (\"@EnumName@\", values);\n  }\n  return etype;\n}\n" \
+       $< > $@
+
+EXTRA_DIST =                   \
+       $(autostart_DATA)       \
+       $(ui_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)