]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Modify Makefile.am for new file names
[empathy.git] / src / Makefile.am
index 2eb2d028666168b7f4ff4b9e8b3ea745f557ca1a..4b1541312e7ac3df189c88049a84fa84dd4ab332 100644 (file)
@@ -1,62 +1,86 @@
-AM_CPPFLAGS =                                                  \
-       -I.                                                     \
-       -I$(top_srcdir)                                         \
-       $(EMPATHY_CFLAGS)                                       \
+AM_CPPFLAGS =                                          \
+       -I$(top_srcdir)                                 \
+       $(EMPATHY_CFLAGS)                               \
+       $(LIBNOTIFY_CFLAGS)                             \
        $(WARN_CFLAGS)
 
-AM_LDFLAGS =                                                   \
-       $(top_builddir)/libempathy/libempathy.la                \
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
+       $(top_builddir)/extensions/libemp-extensions.la         \
+       $(LIBNOTIFY_LIBS)                                       \
        $(EMPATHY_LIBS)
 
-bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
-
-empathy_SOURCES =                                              \
-       empathy-main.c                                          \
-       empathy-filter.c        empathy-filter.h
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_contact_list_SOURCES = empathy-contact-list-main.c
-
-# MC plugin
-#pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
-#libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
-#libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
-#libempathy_filter_plugin_la_LDFLAGS = $(MISSION_CONTROL_PLUGINS_LIBS)
-
-# Dbus service file
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
-       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
-
-chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
-
-autostartdir = $(datadir)/gnome/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
-
-# Empathy filter DBus API
-empathy-filter-glue.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
-empathy-filter-gen.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-client --output=$@ $<
-
-BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service                          \
-       empathy-filter-glue.h                                   \
-       empathy-filter-gen.h
-
-EXTRA_DIST =                                                   \
-       org.gnome.Empathy.Chat.service.in                       \
-       empathy-filter.xml                                      \
-       $(autostart_DATA)                                       \
-       $(chandler_DATA)
+bin_PROGRAMS =                 \
+       empathy                 \
+       empathy-logs
+
+BUILT_SOURCES= \
+       empathy-tube-dispatch-enumtypes.h \
+       empathy-tube-dispatch-enumtypes.c
+
+empathy_SOURCES =                                                      \
+       bacon-message-connection.c bacon-message-connection.h           \
+       empathy.c                                                       \
+       empathy-about-dialog.c empathy-about-dialog.h                   \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h             \
+       empathy-call-window.c empathy-call-window.h                     \
+       empathy-chatrooms-window.c empathy-chatrooms-window.h           \
+       empathy-chat-window.c empathy-chat-window.h                     \
+       empathy-event-manager.c empathy-event-manager.h                 \
+       empathy-ft-manager.c empathy-ft-manager.h                       \
+       empathy-import-dialog.c empathy-import-dialog.h                 \
+       empathy-import-pidgin.c empathy-import-pidgin.h                 \
+       empathy-main-window.c empathy-main-window.h                     \
+       empathy-misc.c empathy-misc.h                                   \
+       empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
+       empathy-preferences.c empathy-preferences.h                     \
+       empathy-sidebar.c empathy-sidebar.h                     \
+       empathy-status-icon.c empathy-status-icon.h                     \
+       empathy-tube-dispatch.c empathy-tube-dispatch.h                 \
+       ephy-spinner.c ephy-spinner.h
+
+nodist_empathy_SOURCES = $(BUILT_SOURCES)
+
+empathy_logs_SOURCES = empathy-logs.c
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-accounts-dialog.ui              \
+       empathy-call-window.ui                  \
+       empathy-chatrooms-window.ui             \
+       empathy-chat-window.ui                  \
+       empathy-ft-manager.ui                   \
+       empathy-import-dialog.ui                \
+       empathy-main-window.ui                  \
+       empathy-new-chatroom-dialog.ui          \
+       empathy-preferences.ui                  \
+       empathy-status-icon.ui
+
+dist_man_MANS =                        \
+       empathy.1
+
+# rules for making the glib enum objects
+%-enumtypes.h: %.h Makefile.in
+       glib-mkenums \
+       --fhead "#ifndef __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n#define __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__\n\n#include <glib-object.h>\n\nG_BEGIN_DECLS\n" \
+       --fprod "/* enumerations from \"@filename@\" */\n" \
+       --vhead "GType @enum_name@_get_type (void);\n#define $(shell echo $* | tr [:lower:]- [:upper:]_ | sed 's/_.*//')_TYPE_@ENUMSHORT@ (@enum_name@_get_type())\n"         \
+       --ftail "G_END_DECLS\n\n#endif /* __$(shell echo $* | tr [:lower:]- [:upper:]_)_ENUM_TYPES_H__ */" \
+       $< > $@
+
+%-enumtypes.c: %.h Makefile.in
+       glib-mkenums \
+       --fhead "#include <$*.h>\n#include <$*-enumtypes.h>" \
+       --fprod "\n/* enumerations from \"@filename@\" */" \
+       --vhead "GType\n@enum_name@_get_type (void)\n{\n  static GType etype = 0;\n  if (etype == 0) {\n    static const G@Type@Value values[] = {"     \
+       --vprod "      { @VALUENAME@, \"@VALUENAME@\", \"@VALUENAME@\" }," \
+       --vtail "      { 0, NULL, NULL }\n    };\n    etype = g_@type@_register_static (\"@EnumName@\", values);\n  }\n  return etype;\n}\n" \
+       $< > $@
+
+EXTRA_DIST =                   \
+       $(autostart_DATA)       \
+       $(ui_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)