]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Rename icons to follow fd.o icon naming spec. Move icons to the right
[empathy.git] / src / Makefile.am
index 0f0c2d0c081cefbdb32548e0e9ef504b2277eaf2..36161fb784b8a6eaa5127969044f608b72ba4ec5 100644 (file)
@@ -1,51 +1,51 @@
-cppflags =                     \
+AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
        -DPREFIX="\"$(prefix)"\"                        \
        -DSYSCONFDIR=\""$(sysconfdir)"\"                \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DLIBDIR=\""$(libdir)"\"                        \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-libs =                                                         \
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
-       empathy-chat            \
-       empathy-accounts
+       empathy-accounts        \
+       empathy-call-chandler
 
-empathy_SOURCES = empathy-main.c
-empathy_CPPFLAGS = $(cppflags)
-empathy_LDADD = $(libs)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
+empathy_call_chandler_SOURCES = empathy-call-chandler.c
 
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cppflags)
-empathy_accounts_LDADD = $(libs)
-
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cppflags)
-empathy_chat_LDADD = $(libs)
-
-# Dbus service file
+# Dbus service files
 servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
+service_DATA =                                                 \
+       org.gnome.Empathy.Chat.service                          \
+       org.gnome.Empathy.Call.service
+%.service: %.service.in Makefile
        @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
 
 chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
+chandler_DATA =                                                        \
+       empathy-chat.chandler
+
+if HAVE_VOIP
+chandler_DATA += empathy-call.chandler
+endif
 
 BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service
+       org.gnome.Empathy.Chat.service                          \
+       org.gnome.Empathy.Call.service
 
 EXTRA_DIST =                                                   \
        org.gnome.Empathy.Chat.service.in                       \
+       org.gnome.Empathy.Call.service.in                       \
        $(autostart_DATA)                                       \
        $(chandler_DATA)