]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Merge branch 'undo-close-tab'
[empathy.git] / src / Makefile.am
index 9460fc9591ad6702e0ececb20b018c2f4eff27f0..18edc7f3f652894367e07ae099d9716d0db16c21 100644 (file)
@@ -13,6 +13,7 @@ CPPFLAGS_COMMON =                                     \
 AM_LDFLAGS = -lm
 AM_CPPFLAGS =                                          \
        $(CPPFLAGS_COMMON)                              \
+       $(TPL_CFLAGS)                                   \
        $(LIBNOTIFY_CFLAGS)                             \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(WEBKIT_CFLAGS)                                \
@@ -22,6 +23,7 @@ LDADD =                                                               \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
        $(top_builddir)/extensions/libemp-extensions.la         \
+       $(TPL_LIBS)                                             \
        $(LIBNOTIFY_LIBS)                                       \
        $(EMPATHY_LIBS)                                         \
        $(LIBCHAMPLAIN_LIBS)                                    \
@@ -79,6 +81,7 @@ endif
 bin_PROGRAMS =                 \
        empathy                 \
        empathy-accounts        \
+       empathy-debugger        \
        $(NULL)
 
 BUILT_SOURCES=
@@ -92,21 +95,27 @@ empathy_accounts_LDADD =                                            \
        libempathy-accounts-common.la                                   \
        $(NULL)
 
+empathy_debugger_SOURCES =                                             \
+       empathy-debug-window.c empathy-debug-window.h                   \
+       empathy-debugger.c                                              \
+       $(NULL)
+
 empathy_handwritten_source = \
        empathy-about-dialog.c empathy-about-dialog.h                   \
        empathy-call-window-fullscreen.c empathy-call-window-fullscreen.h \
        empathy-call-window.c empathy-call-window.h                     \
        empathy-chat-window.c empathy-chat-window.h                     \
        empathy-chatrooms-window.c empathy-chatrooms-window.h           \
-       empathy-debug-window.c empathy-debug-window.h                   \
        empathy-event-manager.c empathy-event-manager.h                 \
        empathy-ft-manager.c empathy-ft-manager.h                       \
        empathy-invite-participant-dialog.c empathy-invite-participant-dialog.h \
        empathy-main-window.c empathy-main-window.h                     \
+       empathy-migrate-butterfly-logs.c empathy-migrate-butterfly-logs.h \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
        empathy-preferences.c empathy-preferences.h                     \
        empathy-sidebar.c empathy-sidebar.h                             \
        empathy-status-icon.c empathy-status-icon.h                     \
+       empathy-chat-manager.c empathy-chat-manager.h                   \
        empathy.c
 
 empathy_SOURCES =                                                      \