]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Move should_create_salut_account to local-xmpp-assistant-widget
[empathy.git] / src / Makefile.am
index ef4e8d964066f6fd73c8026bbf91049695be3b28..06eaf1733e471b2af554dd9522225a3a97c64264 100644 (file)
@@ -59,11 +59,6 @@ libexec_PROGRAMS = \
        empathy-av \
        empathy-chat
 
-BUILT_SOURCES = \
-       src-marshal.h \
-       src-marshal.c \
-       src-marshal.list
-
 empathy_accounts_SOURCES =                                             \
        empathy-accounts.c empathy-accounts.h                           \
        $(NULL)
@@ -102,8 +97,6 @@ empathy_av_SOURCES = \
        empathy-mic-monitor.h
        $(NULL)
 
-nodist_empathy_av_SOURCES = $(BUILT_SOURCES)
-
 empathy_av_CFLAGS = $(EMPATHY_AV_CFLAGS)
 empathy_av_LDFLAGS = $(EMPATHY_AV_LIBS) $(LIBM)
 
@@ -161,8 +154,6 @@ empathy_call_SOURCES = \
        empathy-mic-monitor.c \
        empathy-mic-monitor.h
 
-nodist_empathy_call_SOURCES = $(BUILT_SOURCES)
-
 empathy_call_CFLAGS = $(EMPATHY_CALL_CFLAGS)
 empathy_call_LDFLAGS = $(EMPATHY_CALL_LIBS)
 
@@ -175,7 +166,7 @@ empathy_handwritten_source = \
        empathy-event-manager.c empathy-event-manager.h                 \
        empathy-ft-manager.c empathy-ft-manager.h                       \
        empathy-invite-participant-dialog.c empathy-invite-participant-dialog.h \
-       empathy-main-window.c empathy-main-window.h                     \
+       empathy-roster-window.c empathy-roster-window.h                 \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
        empathy-notifications-approver.c empathy-notifications-approver.h \
        empathy-call-observer.c empathy-call-observer.h                 \
@@ -198,8 +189,6 @@ empathy_LDADD =                                                             \
         $(LIBCHAMPLAIN_LIBS)                                           \
        $(NULL)
 
-nodist_empathy_SOURCES = $(BUILT_SOURCES)
-
 check_c_sources = \
     $(empathy_handwritten_source) \
     $(empathy_logs_SOURCES) \
@@ -218,8 +207,8 @@ ui_DATA =                                   \
        empathy-chatrooms-window.ui             \
        empathy-ft-manager.ui                   \
        empathy-import-dialog.ui                \
-       empathy-main-window.ui                  \
-       empathy-main-window-menubar.ui          \
+       empathy-roster-window.ui                        \
+       empathy-roster-window-menubar.ui                \
        empathy-new-chatroom-dialog.ui          \
        empathy-preferences.ui                  \
        empathy-status-icon.ui
@@ -246,23 +235,3 @@ dist_man_MANS =                    \
        empathy.1 \
        empathy-accounts.1
 
-src-marshal.list: $(empathy_SOURCES) $(empathy_call_SOURCES) Makefile.am
-       $(AM_V_GEN)( cd $(srcdir) && \
-       sed -n -e 's/.*src_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
-       $(empathy_SOURCES) $(empathy_av_SOURCES) $(empathy_call_SOURCES) ) \
-       | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
-       @if cmp -s $@.tmp $@; then \
-               rm $@.tmp; \
-       else \
-               mv $@.tmp $@; \
-       fi
-
-%-marshal.h: %-marshal.list Makefile
-       $(AM_V_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
-
-%-marshal.c: %-marshal.list Makefile
-       $(AM_V_GEN)echo "#include \"src-marshal.h\"" > $@ && \
-       $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
-
-CLEANFILES = $(BUILT_SOURCES)
-