]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
po/POTFILES.in
[empathy.git] / src / Makefile.am
index 86ffade6b1dca987a788302713823552c47392da..05bc6f55a8f8c29ee6a0531e799ef32abc5deaf9 100644 (file)
@@ -1,33 +1,40 @@
-cflags = $(EMPATHY_CFLAGS)                                     \
-        $(WARN_CFLAGS)
+cppflags =                     \
+       -I$(top_srcdir)                                 \
+       -DPREFIX="\"$(prefix)"\"                        \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"                \
+       -DDATADIR=\""$(datadir)"\"                      \
+       -DLIBDIR=\""$(libdir)"\"                        \
+       $(EMPATHY_CFLAGS)       \
+       $(WARN_CFLAGS)
 
-libs = $(top_builddir)/libempathy/libempathy.la                \
+libs =                                                         \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(EMPATHY_LIBS)
 
-bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
+bin_PROGRAMS =                 \
+       empathy                 \
+       empathy-chat            \
+       empathy-accounts
 
-empathy_SOURCES = empathy-main.c
-empathy_CPPFLAGS = $(cflags)
-empathy_LDFLAGS = $(libs)
+empathy_SOURCES =                                              \
+       empathy-main.c                                          \
+       empathy-filter.c        empathy-filter.h
+empathy_CPPFLAGS = $(cppflags)
+empathy_LDADD = $(libs)
 
 empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cflags)
-empathy_accounts_LDFLAGS = $(libs)
+empathy_accounts_CPPFLAGS = $(cppflags)
+empathy_accounts_LDADD = $(libs)
 
 empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cflags)
-empathy_chat_LDFLAGS = $(libs)
-
-empathy_contact_list_SOURCES = empathy-contact-list-main.c
-empathy_contact_list_CPPFLAGS = $(cflags)
-empathy_contact_list_LDFLAGS = $(libs)
+empathy_chat_CPPFLAGS = $(cppflags)
+empathy_chat_LDADD = $(libs)
 
 # MC plugin
-pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
-libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
-libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
-libempathy_filter_plugin_la_LDFLAGS = $(MISSION_CONTROL_PLUGINS_LIBS)
+#pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
+#libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
+#libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
+#libempathy_filter_plugin_la_LIBADD = $(MISSION_CONTROL_PLUGINS_LIBS)
 
 # Dbus service file
 servicedir = $(datadir)/dbus-1/services
@@ -41,16 +48,20 @@ $(service_DATA): $(service_in_files) Makefile
 chandlerdir = $(datadir)/telepathy/managers
 chandler_DATA = empathy-chat.chandler
 
-autostartdir = $(datadir)/gnome/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
-@INTLTOOL_DESKTOP_RULE@
+# Empathy filter DBus API
+empathy-filter-glue.h: empathy-filter.xml
+       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
+empathy-filter-gen.h: empathy-filter.xml
+       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-client --output=$@ $<
 
 BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service
+       org.gnome.Empathy.Chat.service                          \
+       empathy-filter-glue.h                                   \
+       empathy-filter-gen.h
 
 EXTRA_DIST =                                                   \
        org.gnome.Empathy.Chat.service.in                       \
+       empathy-filter.xml                                      \
        $(autostart_DATA)                                       \
        $(chandler_DATA)