]> git.0d.be Git - empathy.git/blobdiff - python/pyempathy/Makefile.am
Merge commit 'bigon/configure-deprecated-flag'
[empathy.git] / python / pyempathy / Makefile.am
index c11eedbc3830950ae13201f960d665e5f7b998c8..8ec61ff8e99815765436425f10f59028d2cc9e00 100644 (file)
@@ -3,11 +3,13 @@ PYDEFS=`pkg-config --variable=defsdir pygtk-2.0`
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)/libempathy                      \
+       -I$(top_builddir)/libempathy                    \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        $(PYTHON_BINDING_CFLAGS)                        \
-       `python-config --cflags`                        \
-       $(WARN_CFLAGS)
+       $(PYTHON_INCLUDES)                              \
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        pyempathy.c                                     
@@ -16,7 +18,9 @@ pyempathydir = $(pyexecdir)
 pyempathy_LTLIBRARIES = empathy.la
 
 empathy_la_SOURCES =                                   \
-       pyempathymodule.c                               \
+       pyempathymodule.c
+
+nodist_empathy_la_SOURCES =                            \
        pyempathy.c
 
 empathy_la_LIBADD =                                    \
@@ -24,16 +28,15 @@ empathy_la_LIBADD =                                 \
        $(top_builddir)/libempathy/libempathy.la
 
 empathy_la_LDFLAGS =                                   \
-       `python-config --libs`                          \
        -module -avoid-version
 
 pyempathy.c: pyempathy.override pyempathy.defs
-       pygtk-codegen-2.0                               \
+       $(PYGOBJECTCODEGEN)                             \
                --prefix empathy                        \
                --register $(PYDEFS)/gdk-types.defs     \
                --register $(PYDEFS)/gtk-types.defs     \
-               --override pyempathy.override           \
-               pyempathy.defs > $@ 
+               --override $(srcdir)/pyempathy.override \
+               $(srcdir)/pyempathy.defs > $@ 
 
 EXTRA_DIST =                   \
        pyempathy.override      \