]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Move empathy-contact-groups to libempathy, it has nothing to do in -gtk
[empathy.git] / libempathy / Makefile.am
index 9dc4021e2abc11e23154ba057f402fbf028b3ece..e6711c3c642e993045c770ee00747c3f2d57da39 100644 (file)
@@ -20,20 +20,24 @@ libempathy_la_SOURCES =                                     \
        empathy-avatar.c                                \
        empathy-time.c                                  \
        empathy-presence.c                              \
+       empathy-status-presets.c                        \
        empathy-debug.c                                 \
        empathy-utils.c                                 \
        empathy-message.c                               \
        empathy-chatroom-manager.c                      \
        empathy-chatroom.c                              \
        empathy-contact.c                               \
+       empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
        empathy-contact-factory.c                       \
+       empathy-tp-contact-factory.c                    \
        empathy-tp-group.c                              \
        empathy-tp-contact-list.c                       \
        empathy-tp-chat.c                               \
        empathy-tp-chatroom.c                           \
        empathy-tp-roomlist.c                           \
+       empathy-tp-call.c                               \
        empathy-chandler.c                              \
        empathy-filter.c                                \
        empathy-idle.c                                  \
@@ -54,24 +58,29 @@ libempathy_headers =                                \
        empathy-avatar.h                        \
        empathy-time.h                          \
        empathy-presence.h                      \
+       empathy-status-presets.h                \
        empathy-debug.h                         \
        empathy-utils.h                         \
        empathy-message.h                       \
        empathy-chatroom-manager.h              \
        empathy-chatroom.h                      \
        empathy-contact.h                       \
+       empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
        empathy-contact-factory.h               \
+       empathy-tp-contact-factory.h            \
        empathy-tp-group.h                      \
        empathy-tp-contact-list.h               \
        empathy-tp-chat.h                       \
        empathy-tp-chatroom.h                   \
        empathy-tp-roomlist.h                   \
+       empathy-tp-call.h                       \
        empathy-chandler.h                      \
        empathy-filter.h                        \
        empathy-idle.h                          \
-       empathy-log-manager.h
+       empathy-log-manager.h                   \
+       tp-stream-engine-gen.h
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
@@ -90,6 +99,10 @@ empathy-chandler-glue.h: empathy-chandler.xml Makefile
 empathy-filter-glue.h: empathy-filter.xml Makefile
        $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
 
+tp-stream-engine-gen.h: tp-stream-engine.xml Makefile.am
+       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=tp_stream_engine --mode=glib-client --output=$@ $<
+
+
 empathy-enum-types.h: stamp-empathy-enum-types.h
        @true
 stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
@@ -130,6 +143,8 @@ empathy-enum-types.c: $(libempathy_headers) Makefile
 
 dtddir = $(datadir)/empathy
 dtd_DATA =                                     \
+       empathy-status-presets.dtd              \
+       empathy-contact-groups.dtd              \
        empathy-chatroom-manager.dtd
 
 stylesheetdir = $(datadir)/empathy
@@ -143,6 +158,7 @@ EXTRA_DIST =                        \
        empathy-marshal.list    \
        empathy-chandler.xml    \
        empathy-filter.xml      \
+       tp-stream-engine.xml    \
        $(stylesheet_DATA)      \
        $(dtd_DATA)