]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Updated Basque language
[empathy.git] / libempathy / Makefile.am
index d7c9263cb4031c2435e677b5630e564310716e11..e45b16d811474070ad1427d3e803942e1a08e32b 100644 (file)
@@ -1,4 +1,5 @@
 include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        -I.                                             \
@@ -6,7 +7,11 @@ AM_CPPFLAGS =                                           \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       -DG_LOG_DOMAIN=\"empathy\"                      \
        $(LIBEMPATHY_CFLAGS)                            \
+       $(GEOCLUE_CFLAGS)                               \
+       $(NETWORK_MANAGER_CFLAGS)                       \
+       $(CONNMAN_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -20,19 +25,27 @@ BUILT_SOURCES =                                     \
 lib_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                        \
+       empathy-account.c                       \
+       empathy-account-settings.c                      \
        empathy-account-manager.c                       \
        empathy-chatroom.c                              \
        empathy-chatroom-manager.c                      \
        empathy-call-factory.c                          \
        empathy-call-handler.c                          \
+       empathy-connectivity.c                          \
        empathy-contact.c                               \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
        empathy-contact-monitor.c                       \
+       empathy-connection-managers.c                   \
        empathy-debug.c                                 \
+       empathy-debugger.c                              \
        empathy-dispatcher.c                            \
        empathy-dispatch-operation.c                    \
+       empathy-ft-factory.c                            \
+       empathy-ft-handler.c                            \
+       empathy-handler.c                               \
        empathy-idle.c                                  \
        empathy-irc-network.c                           \
        empathy-irc-network-manager.c                   \
@@ -49,7 +62,6 @@ libempathy_la_SOURCES =                                       \
        empathy-tp-contact-list.c                       \
        empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
-       empathy-tp-tube.c                               \
        empathy-tube-handler.c                          \
        empathy-utils.c
 
@@ -59,26 +71,37 @@ nodist_libempathy_la_SOURCES =\
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
-       $(LIBEMPATHY_LIBS)
+       $(LIBEMPATHY_LIBS) \
+       $(GEOCLUE_LIBS) \
+       $(NETWORK_MANAGER_LIBS) \
+       $(CONNMAN_LIBS)
 
 libempathy_la_LDFLAGS =                \
        -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
        -export-symbols-regex ^empathy_
 
 libempathy_headers =                           \
+       empathy-account-settings.h              \
+       empathy-account.h                       \
        empathy-account-manager.h               \
        empathy-chatroom.h                      \
        empathy-chatroom-manager.h              \
        empathy-call-factory.h                  \
        empathy-call-handler.h                  \
+       empathy-connectivity.h                  \
        empathy-contact.h                       \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
        empathy-contact-monitor.h               \
+       empathy-connection-managers.h           \
        empathy-debug.h                         \
+       empathy-debugger.h                      \
        empathy-dispatcher.h                    \
        empathy-dispatch-operation.h            \
+       empathy-ft-factory.h                    \
+       empathy-ft-handler.h                    \
+       empathy-handler.h                       \
        empathy-idle.h                          \
        empathy-irc-network.h                   \
        empathy-irc-network-manager.h           \
@@ -96,7 +119,6 @@ libempathy_headers =                         \
        empathy-tp-contact-list.h               \
        empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
-       empathy-tp-tube.h                       \
        empathy-tube-handler.h                  \
        empathy-types.h                         \
        empathy-utils.h