]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Add empathy_tp_chat_get_connection() to direct access the channel's connection.
[empathy.git] / libempathy / Makefile.am
index 94ee1b1038466c1a712df17bbaed81000bbd13a5..d035f88159d477daaef8bfcf42b207977d9ed209 100644 (file)
@@ -3,8 +3,10 @@ AM_CPPFLAGS =                                           \
        -I$(top_srcdir)                                 \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
@@ -16,21 +18,26 @@ BUILT_SOURCES =                                     \
 lib_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                        \
+       empathy-account-manager.c                       \
        empathy-chatroom.c                              \
        empathy-chatroom-manager.c                      \
+       empathy-call-factory.c                          \
+       empathy-call-handler.c                          \
        empathy-contact.c                               \
-       empathy-contact-factory.c                       \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
+       empathy-contact-monitor.c                       \
        empathy-debug.c                                 \
        empathy-dispatcher.c                            \
-       empathy-file.c                                  \
+       empathy-dispatch-operation.c                    \
        empathy-idle.c                                  \
        empathy-irc-network.c                           \
        empathy-irc-network-manager.c                   \
        empathy-irc-server.c                            \
        empathy-log-manager.c                           \
+       empathy-log-store.c                             \
+       empathy-log-store-empathy.c                     \
        empathy-message.c                               \
        empathy-status-presets.c                        \
        empathy-time.c                                  \
@@ -39,7 +46,6 @@ libempathy_la_SOURCES =                                       \
        empathy-tp-contact-factory.c                    \
        empathy-tp-contact-list.c                       \
        empathy-tp-file.c                               \
-       empathy-tp-file-priv.h                          \
        empathy-tp-group.c                              \
        empathy-tp-roomlist.c                           \
        empathy-tp-tube.c                               \
@@ -59,21 +65,26 @@ libempathy_la_LDFLAGS =             \
        -export-symbols-regex ^empathy_
 
 libempathy_headers =                           \
+       empathy-account-manager.h               \
        empathy-chatroom.h                      \
        empathy-chatroom-manager.h              \
+       empathy-call-factory.h                  \
+       empathy-call-handler.h                  \
        empathy-contact.h                       \
-       empathy-contact-factory.h               \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
+       empathy-contact-monitor.h               \
        empathy-debug.h                         \
        empathy-dispatcher.h                    \
-       empathy-file.h                          \
+       empathy-dispatch-operation.h            \
        empathy-idle.h                          \
        empathy-irc-network.h                   \
        empathy-irc-network-manager.h           \
        empathy-irc-server.h                    \
        empathy-log-manager.h                   \
+       empathy-log-store.h                     \
+       empathy-log-store-empathy.h             \
        empathy-message.h                       \
        empathy-status-presets.h                \
        empathy-time.h                          \
@@ -86,6 +97,7 @@ libempathy_headers =                          \
        empathy-tp-roomlist.h                   \
        empathy-tp-tube.h                       \
        empathy-tube-handler.h                  \
+       empathy-types.h                         \
        empathy-utils.h
 
 libempathy_includedir = $(includedir)/libempathy/