]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Add empathy_tp_chat_get_connection() to direct access the channel's connection.
[empathy.git] / libempathy / Makefile.am
index 559d869a703194d718fc1248df89c691013c8f12..d035f88159d477daaef8bfcf42b207977d9ed209 100644 (file)
@@ -5,7 +5,8 @@ AM_CPPFLAGS =                                           \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
@@ -20,8 +21,9 @@ libempathy_la_SOURCES =                                       \
        empathy-account-manager.c                       \
        empathy-chatroom.c                              \
        empathy-chatroom-manager.c                      \
+       empathy-call-factory.c                          \
+       empathy-call-handler.c                          \
        empathy-contact.c                               \
-       empathy-contact-factory.c                       \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
@@ -34,6 +36,8 @@ libempathy_la_SOURCES =                                       \
        empathy-irc-network-manager.c                   \
        empathy-irc-server.c                            \
        empathy-log-manager.c                           \
+       empathy-log-store.c                             \
+       empathy-log-store-empathy.c                     \
        empathy-message.c                               \
        empathy-status-presets.c                        \
        empathy-time.c                                  \
@@ -64,8 +68,9 @@ libempathy_headers =                          \
        empathy-account-manager.h               \
        empathy-chatroom.h                      \
        empathy-chatroom-manager.h              \
+       empathy-call-factory.h                  \
+       empathy-call-handler.h                  \
        empathy-contact.h                       \
-       empathy-contact-factory.h               \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
@@ -78,6 +83,8 @@ libempathy_headers =                          \
        empathy-irc-network-manager.h           \
        empathy-irc-server.h                    \
        empathy-log-manager.h                   \
+       empathy-log-store.h                     \
+       empathy-log-store-empathy.h             \
        empathy-message.h                       \
        empathy-status-presets.h                \
        empathy-time.h                          \