]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge branch 'ft_rework'
[empathy.git] / libempathy / Makefile.am
index b952be270ee0137a816ff633de18407326909e23..c9f2c42061c37c7e4ea1ce7f72000841c909dc5d 100644 (file)
+include $(top_srcdir)/tools/shave.mk
+
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)                                 \
+       -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
-       $(WARN_CFLAGS)
+       $(GEOCLUE_CFLAGS)                               \
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
        empathy-marshal.c                               \
        empathy-marshal.list                            \
        empathy-enum-types.h                            \
-       empathy-enum-types.c                            \
-       empathy-filter-glue.h                           \
-       empathy-chandler-glue.h                         \
-       tp-stream-engine-gen.h
+       empathy-enum-types.c
 
 lib_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                        \
-       empathy-avatar.c                                \
-       empathy-time.c                                  \
-       empathy-status-presets.c                        \
-       empathy-debug.c                                 \
-       empathy-utils.c                                 \
-       empathy-message.c                               \
-       empathy-chatroom-manager.c                      \
+       empathy-account-manager.c                       \
        empathy-chatroom.c                              \
+       empathy-chatroom-manager.c                      \
+       empathy-call-factory.c                          \
+       empathy-call-handler.c                          \
        empathy-contact.c                               \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
-       empathy-contact-factory.c                       \
+       empathy-contact-monitor.c                       \
+       empathy-debug.c                                 \
+       empathy-dispatcher.c                            \
+       empathy-dispatch-operation.c                    \
+       empathy-ft-factory.c                            \
+       empathy-ft-handler.c                            \
+       empathy-idle.c                                  \
+       empathy-irc-network.c                           \
+       empathy-irc-network-manager.c                   \
+       empathy-irc-server.c                            \
+       empathy-log-manager.c                           \
+       empathy-log-store.c                             \
+       empathy-log-store-empathy.c                     \
+       empathy-message.c                               \
+       empathy-status-presets.c                        \
+       empathy-time.c                                  \
+       empathy-tp-call.c                               \
+       empathy-tp-chat.c                               \
        empathy-tp-contact-factory.c                    \
-       empathy-tp-group.c                              \
        empathy-tp-contact-list.c                       \
-       empathy-tp-chat.c                               \
-       empathy-tp-chatroom.c                           \
+       empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
-       empathy-tp-call.c                               \
-       empathy-chandler.c                              \
-       empathy-filter.c                                \
-       empathy-idle.c                                  \
-       empathy-log-manager.c                           \
-       empathy-irc-network-manager.c                   \
-       empathy-irc-network.c                           \
-       empathy-irc-server.c
+       empathy-tp-tube.c                               \
+       empathy-tube-handler.c                          \
+       empathy-utils.c
 
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_la_LIBADD =         \
-       $(LIBEMPATHY_LIBS)
+       $(top_builddir)/extensions/libemp-extensions.la \
+       $(LIBEMPATHY_LIBS) \
+       $(GEOCLUE_LIBS)
 
 libempathy_la_LDFLAGS =                \
        -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
        -export-symbols-regex ^empathy_
 
 libempathy_headers =                           \
-       empathy-avatar.h                        \
-       empathy-time.h                          \
-       empathy-status-presets.h                \
-       empathy-debug.h                         \
-       empathy-utils.h                         \
-       empathy-message.h                       \
-       empathy-chatroom-manager.h              \
+       empathy-account-manager.h               \
        empathy-chatroom.h                      \
+       empathy-chatroom-manager.h              \
+       empathy-call-factory.h                  \
+       empathy-call-handler.h                  \
        empathy-contact.h                       \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
-       empathy-contact-factory.h               \
+       empathy-contact-monitor.h               \
+       empathy-debug.h                         \
+       empathy-dispatcher.h                    \
+       empathy-dispatch-operation.h            \
+       empathy-ft-factory.h                    \
+       empathy-ft-handler.h                    \
+       empathy-idle.h                          \
+       empathy-irc-network.h                   \
+       empathy-irc-network-manager.h           \
+       empathy-irc-server.h                    \
+       empathy-location.h                      \
+       empathy-log-manager.h                   \
+       empathy-log-store.h                     \
+       empathy-log-store-empathy.h             \
+       empathy-message.h                       \
+       empathy-status-presets.h                \
+       empathy-time.h                          \
+       empathy-tp-call.h                       \
+       empathy-tp-chat.h                       \
        empathy-tp-contact-factory.h            \
-       empathy-tp-group.h                      \
        empathy-tp-contact-list.h               \
-       empathy-tp-chat.h                       \
-       empathy-tp-chatroom.h                   \
+       empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
-       empathy-tp-call.h                       \
-       empathy-chandler.h                      \
-       empathy-filter.h                        \
-       empathy-idle.h                          \
-       empathy-log-manager.h                   \
-       empathy-irc-network-manager.h           \
-       empathy-irc-network.h                   \
-       empathy-irc-server.h
+       empathy-tp-tube.h                       \
+       empathy-tube-handler.h                  \
+       empathy-types.h                         \
+       empathy-utils.h
+
+check_c_sources = \
+    $(libempathy_la_SOURCES) \
+    $(libempathy_headers)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
@@ -92,8 +119,8 @@ libempathy_include_HEADERS =                 \
        empathy-enum-types.h
 
 empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
-       ( cd $(srcdir) && \
-       sed -n -e 's/.*empathy_marshal_\([[:upper:]]*__[[:upper:]_]*\).*/\1/p' \
+       $(QUIET_GEN)( cd $(srcdir) && \
+       sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
        if cmp -s $@.tmp $@; then \
@@ -103,25 +130,16 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
        fi
 
 %-marshal.h: %-marshal.list Makefile
-       $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
-       echo "#include \"empathy-marshal.h\"" > $@ && \
+       $(QUIET_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
-empathy-chandler-glue.h: empathy-chandler.xml Makefile
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<
-empathy-filter-glue.h: empathy-filter.xml Makefile
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
-
-tp-stream-engine-gen.h: tp-stream-engine.xml Makefile.am
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=tp_stream_engine --mode=glib-client --output=$@ $<
-
-
 empathy-enum-types.h: stamp-empathy-enum-types.h
-       @true
+       $(QUIET_GEN)true
 stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_ENUM_TYPES_H__ 1\n\n" \
@@ -138,7 +156,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
        && echo timestamp > $(@F)
 
 empathy-enum-types.c: $(libempathy_headers) Makefile
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -176,9 +194,6 @@ pkgconfig_DATA = libempathy.pc
 
 EXTRA_DIST =                   \
        empathy-marshal.list    \
-       empathy-chandler.xml    \
-       empathy-filter.xml      \
-       tp-stream-engine.xml    \
        $(stylesheet_DATA)      \
        $(dtd_DATA)             \
        $(ircnetworks_DATA)