]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge branch 'sasl'
[empathy.git] / libempathy / Makefile.am
index fa62d0cd793b821d295bc9a3337a7799872602d9..ae9e2b5e9bf720356600a2d124da315ae541db75 100644 (file)
@@ -8,7 +8,7 @@ AM_CPPFLAGS =                                           \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        -DG_LOG_DOMAIN=\"empathy\"                      \
-       $(LIBEMPATHY_CFLAGS)                            \
+       $(EMPATHY_CFLAGS)                               \
        $(GEOCLUE_CFLAGS)                               \
        $(NETWORK_MANAGER_CFLAGS)                       \
        $(CONNMAN_CFLAGS)                               \
@@ -26,6 +26,7 @@ noinst_LTLIBRARIES = libempathy.la
 
 libempathy_headers =                           \
        empathy-account-settings.h              \
+       empathy-auth-factory.h                  \
        empathy-call-factory.h                  \
        empathy-call-handler.h                  \
        empathy-chatroom-manager.h              \
@@ -35,26 +36,26 @@ libempathy_headers =                                \
        empathy-contact-groups.h                \
        empathy-contact-list.h                  \
        empathy-contact-manager.h               \
-       empathy-contact-monitor.h               \
        empathy-contact.h                       \
        empathy-debug.h                         \
-       empathy-debugger.h                      \
-       empathy-dispatch-operation.h            \
        empathy-dispatcher.h                    \
        empathy-ft-factory.h                    \
        empathy-ft-handler.h                    \
-       empathy-handler.h                       \
+       empathy-gsettings.h                     \
        empathy-idle.h                          \
+       empathy-individual-manager.h            \
        empathy-irc-network-manager.h           \
        empathy-irc-network.h                   \
        empathy-irc-server.h                    \
+       empathy-keyring.h                       \
        empathy-location.h                      \
-       empathy-log-manager.h                   \
-       empathy-log-store-empathy.h             \
-       empathy-log-store.h                     \
        empathy-message.h                       \
+       empathy-server-sasl-handler.h           \
+       empathy-server-tls-handler.h            \
        empathy-status-presets.h                \
        empathy-time.h                          \
+       empathy-tls-certificate.h               \
+       empathy-tls-verifier.h                  \
        empathy-tp-call.h                       \
        empathy-tp-chat.h                       \
        empathy-tp-contact-factory.h            \
@@ -67,6 +68,7 @@ libempathy_headers =                          \
 libempathy_la_SOURCES =                                        \
        $(libempathy_headers)                           \
        empathy-account-settings.c                      \
+       empathy-auth-factory.c                          \
        empathy-call-factory.c                          \
        empathy-call-handler.c                          \
        empathy-chatroom-manager.c                      \
@@ -76,25 +78,24 @@ libempathy_la_SOURCES =                                     \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
-       empathy-contact-monitor.c                       \
        empathy-contact.c                               \
        empathy-debug.c                                 \
-       empathy-debugger.c                              \
-       empathy-dispatch-operation.c                    \
        empathy-dispatcher.c                            \
        empathy-ft-factory.c                            \
        empathy-ft-handler.c                            \
-       empathy-handler.c                               \
        empathy-idle.c                                  \
+       empathy-individual-manager.c                    \
        empathy-irc-network-manager.c                   \
        empathy-irc-network.c                           \
        empathy-irc-server.c                            \
-       empathy-log-manager.c                           \
-       empathy-log-store-empathy.c                     \
-       empathy-log-store.c                             \
+       empathy-keyring.c                               \
        empathy-message.c                               \
+       empathy-server-sasl-handler.c                   \
+       empathy-server-tls-handler.c                    \
        empathy-status-presets.c                        \
        empathy-time.c                                  \
+       empathy-tls-certificate.c                       \
+       empathy-tls-verifier.c                          \
        empathy-tp-call.c                               \
        empathy-tp-chat.c                               \
        empathy-tp-contact-factory.c                    \
@@ -109,7 +110,7 @@ nodist_libempathy_la_SOURCES =\
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
-       $(LIBEMPATHY_LIBS) \
+       $(EMPATHY_LIBS) \
        $(GEOCLUE_LIBS) \
        $(NETWORK_MANAGER_LIBS) \
        $(CONNMAN_LIBS)
@@ -183,17 +184,12 @@ dtd_DATA =                                        \
        empathy-chatroom-manager.dtd            \
        empathy-irc-networks.dtd
 
-stylesheetdir = $(datadir)/empathy
-stylesheet_DATA =              \
-       empathy-log-manager.xsl
-
 ircnetworksdir = $(datadir)/empathy
 ircnetworks_DATA =             \
        irc-networks.xml
 
 EXTRA_DIST =                   \
        empathy-marshal.list    \
-       $(stylesheet_DATA)      \
        $(dtd_DATA)             \
        $(ircnetworks_DATA)