]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
[darcs-to-svn @ Cleanup build system and add MC plugin]
[empathy.git] / libempathy / Makefile.am
index c681aa83f9e2d2c18967f93a37e1b28631d0d7d7..98349b205dfe21b83ebc6fd2af7cc8c74c86effb 100644 (file)
@@ -1,11 +1,12 @@
 AM_CPPFLAGS =                                           \
-       -I.                                             \
-       -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
-       $(EMPATHY_CFLAGS)                               \
+       $(LIBEMPATHY_CFLAGS)                            \
        $(WARN_CFLAGS)
 
+AM_LDFLAGS =                                           \
+       $(LIBEMPATHY_LIBS)
+
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
        empathy-marshal.c                               \
@@ -30,9 +31,6 @@ libempathy_la_SOURCES =                                                       \
        empathy-chandler.c              empathy-chandler.h                      \
        empathy-marshal-main.c
 
-libempathy_la_LIBADD =                                 \
-       $(EMPATHY_LIBS)
-
 libempathy_includedir = $(includedir)/empathy/
 
 %-marshal.h: %-marshal.list Makefile.am