]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge branch 'debugger'
[empathy.git] / libempathy / Makefile.am
index d7c9263cb4031c2435e677b5630e564310716e11..87b7284643ebe58a4531569c58c45fcbf24461cd 100644 (file)
@@ -1,4 +1,5 @@
 include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        -I.                                             \
@@ -6,7 +7,9 @@ AM_CPPFLAGS =                                           \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       -DG_LOG_DOMAIN=\"empathy\"                      \
        $(LIBEMPATHY_CFLAGS)                            \
+       $(GEOCLUE_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -31,8 +34,11 @@ libempathy_la_SOURCES =                                      \
        empathy-contact-manager.c                       \
        empathy-contact-monitor.c                       \
        empathy-debug.c                                 \
+       empathy-debugger.c                              \
        empathy-dispatcher.c                            \
        empathy-dispatch-operation.c                    \
+       empathy-ft-factory.c                            \
+       empathy-ft-handler.c                            \
        empathy-idle.c                                  \
        empathy-irc-network.c                           \
        empathy-irc-network-manager.c                   \
@@ -49,7 +55,6 @@ libempathy_la_SOURCES =                                       \
        empathy-tp-contact-list.c                       \
        empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
-       empathy-tp-tube.c                               \
        empathy-tube-handler.c                          \
        empathy-utils.c
 
@@ -59,7 +64,8 @@ nodist_libempathy_la_SOURCES =\
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
-       $(LIBEMPATHY_LIBS)
+       $(LIBEMPATHY_LIBS) \
+       $(GEOCLUE_LIBS)
 
 libempathy_la_LDFLAGS =                \
        -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
@@ -77,8 +83,11 @@ libempathy_headers =                         \
        empathy-contact-manager.h               \
        empathy-contact-monitor.h               \
        empathy-debug.h                         \
+       empathy-debugger.h                      \
        empathy-dispatcher.h                    \
        empathy-dispatch-operation.h            \
+       empathy-ft-factory.h                    \
+       empathy-ft-handler.h                    \
        empathy-idle.h                          \
        empathy-irc-network.h                   \
        empathy-irc-network-manager.h           \
@@ -96,7 +105,6 @@ libempathy_headers =                         \
        empathy-tp-contact-list.h               \
        empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
-       empathy-tp-tube.h                       \
        empathy-tube-handler.h                  \
        empathy-types.h                         \
        empathy-utils.h