]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge branch 'debugger'
[empathy.git] / libempathy / Makefile.am
index c9f2c42061c37c7e4ea1ce7f72000841c909dc5d..87b7284643ebe58a4531569c58c45fcbf24461cd 100644 (file)
@@ -1,4 +1,5 @@
 include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        -I.                                             \
@@ -6,6 +7,7 @@ AM_CPPFLAGS =                                           \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       -DG_LOG_DOMAIN=\"empathy\"                      \
        $(LIBEMPATHY_CFLAGS)                            \
        $(GEOCLUE_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
@@ -32,6 +34,7 @@ libempathy_la_SOURCES =                                       \
        empathy-contact-manager.c                       \
        empathy-contact-monitor.c                       \
        empathy-debug.c                                 \
+       empathy-debugger.c                              \
        empathy-dispatcher.c                            \
        empathy-dispatch-operation.c                    \
        empathy-ft-factory.c                            \
@@ -52,7 +55,6 @@ libempathy_la_SOURCES =                                       \
        empathy-tp-contact-list.c                       \
        empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
-       empathy-tp-tube.c                               \
        empathy-tube-handler.c                          \
        empathy-utils.c
 
@@ -81,6 +83,7 @@ libempathy_headers =                          \
        empathy-contact-manager.h               \
        empathy-contact-monitor.h               \
        empathy-debug.h                         \
+       empathy-debugger.h                      \
        empathy-dispatcher.h                    \
        empathy-dispatch-operation.h            \
        empathy-ft-factory.h                    \
@@ -102,7 +105,6 @@ libempathy_headers =                                \
        empathy-tp-contact-list.h               \
        empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
-       empathy-tp-tube.h                       \
        empathy-tube-handler.h                  \
        empathy-types.h                         \
        empathy-utils.h