]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge branch 'debugger'
[empathy.git] / libempathy / Makefile.am
index ba1f6f8c71cba5edeac9e722e949aa90aa89345c..87b7284643ebe58a4531569c58c45fcbf24461cd 100644 (file)
@@ -1,10 +1,15 @@
+include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
+
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       -DG_LOG_DOMAIN=\"empathy\"                      \
        $(LIBEMPATHY_CFLAGS)                            \
+       $(GEOCLUE_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -29,8 +34,11 @@ libempathy_la_SOURCES =                                      \
        empathy-contact-manager.c                       \
        empathy-contact-monitor.c                       \
        empathy-debug.c                                 \
+       empathy-debugger.c                              \
        empathy-dispatcher.c                            \
        empathy-dispatch-operation.c                    \
+       empathy-ft-factory.c                            \
+       empathy-ft-handler.c                            \
        empathy-idle.c                                  \
        empathy-irc-network.c                           \
        empathy-irc-network-manager.c                   \
@@ -47,7 +55,6 @@ libempathy_la_SOURCES =                                       \
        empathy-tp-contact-list.c                       \
        empathy-tp-file.c                               \
        empathy-tp-roomlist.c                           \
-       empathy-tp-tube.c                               \
        empathy-tube-handler.c                          \
        empathy-utils.c
 
@@ -57,7 +64,8 @@ nodist_libempathy_la_SOURCES =\
 
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
-       $(LIBEMPATHY_LIBS)
+       $(LIBEMPATHY_LIBS) \
+       $(GEOCLUE_LIBS)
 
 libempathy_la_LDFLAGS =                \
        -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
@@ -75,12 +83,16 @@ libempathy_headers =                                \
        empathy-contact-manager.h               \
        empathy-contact-monitor.h               \
        empathy-debug.h                         \
+       empathy-debugger.h                      \
        empathy-dispatcher.h                    \
        empathy-dispatch-operation.h            \
+       empathy-ft-factory.h                    \
+       empathy-ft-handler.h                    \
        empathy-idle.h                          \
        empathy-irc-network.h                   \
        empathy-irc-network-manager.h           \
        empathy-irc-server.h                    \
+       empathy-location.h                      \
        empathy-log-manager.h                   \
        empathy-log-store.h                     \
        empathy-log-store-empathy.h             \
@@ -93,18 +105,23 @@ libempathy_headers =                               \
        empathy-tp-contact-list.h               \
        empathy-tp-file.h                       \
        empathy-tp-roomlist.h                   \
-       empathy-tp-tube.h                       \
        empathy-tube-handler.h                  \
        empathy-types.h                         \
        empathy-utils.h
 
+check_c_sources = \
+    $(libempathy_la_SOURCES) \
+    $(libempathy_headers)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
        $(libempathy_headers)                   \
        empathy-enum-types.h
 
 empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
-       ( cd $(srcdir) && \
+       $(QUIET_GEN)( cd $(srcdir) && \
        sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
@@ -115,16 +132,16 @@ empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
        fi
 
 %-marshal.h: %-marshal.list Makefile
-       $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
-       echo "#include \"empathy-marshal.h\"" > $@ && \
+       $(QUIET_GEN)echo "#include \"empathy-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-enum-types.h: stamp-empathy-enum-types.h
-       @true
+       $(QUIET_GEN)true
 stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_ENUM_TYPES_H__ 1\n\n" \
@@ -141,7 +158,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
        && echo timestamp > $(@F)
 
 empathy-enum-types.c: $(libempathy_headers) Makefile
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \