]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Updated.
[empathy.git] / libempathy / Makefile.am
index 639d22ecbb81ca5808f0bc181fee8ae429c30366..6d66c932160f0119109ebcd6b4c944b56bd853b6 100644 (file)
@@ -34,6 +34,7 @@ libempathy_la_SOURCES =                                       \
        empathy-tp-chat.c                               \
        empathy-tp-chatroom.c                           \
        empathy-tp-roomlist.c                           \
+       empathy-tp-call.c                               \
        empathy-chandler.c                              \
        empathy-filter.c                                \
        empathy-idle.c                                  \
@@ -68,31 +69,37 @@ libempathy_headers =                                \
        empathy-tp-chat.h                       \
        empathy-tp-chatroom.h                   \
        empathy-tp-roomlist.h                   \
+       empathy-tp-call.h                       \
        empathy-chandler.h                      \
        empathy-filter.h                        \
        empathy-idle.h                          \
-       empathy-log-manager.h
+       empathy-log-manager.h                   \
+       tp-stream-engine-gen.h
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \
        $(libempathy_headers)                   \
        empathy-enum-types.h
 
-%-marshal.h: %-marshal.list Makefile.am
+%-marshal.h: %-marshal.list Makefile
        $(GLIB_GENMARSHAL) --header --prefix=$(subst -,_,$*)_marshal $< > $*-marshal.h
 
-%-marshal.c: %-marshal.list Makefile.am
+%-marshal.c: %-marshal.list Makefile
        echo "#include \"empathy-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
-empathy-chandler-glue.h: empathy-chandler.xml
+empathy-chandler-glue.h: empathy-chandler.xml Makefile
        $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<
-empathy-filter-glue.h: empathy-filter.xml
+empathy-filter-glue.h: empathy-filter.xml Makefile
        $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
 
+tp-stream-engine-gen.h: tp-stream-engine.xml Makefile.am
+       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=tp_stream_engine --mode=glib-client --output=$@ $<
+
+
 empathy-enum-types.h: stamp-empathy-enum-types.h
        @true
-stamp-empathy-enum-types.h: Makefile $(libempathy_headers)
+stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
        (cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_ENUM_TYPES_H__\n" \
@@ -109,7 +116,7 @@ stamp-empathy-enum-types.h: Makefile $(libempathy_headers)
        && rm -f xgen-gth \
        && echo timestamp > $(@F)
 
-empathy-enum-types.c: Makefile $(libempathy_headers)
+empathy-enum-types.c: $(libempathy_headers) Makefile
        (cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
@@ -143,6 +150,7 @@ EXTRA_DIST =                        \
        empathy-marshal.list    \
        empathy-chandler.xml    \
        empathy-filter.xml      \
+       tp-stream-engine.xml    \
        $(stylesheet_DATA)      \
        $(dtd_DATA)