]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
EmpathyContactList is now an interface implemented by
[empathy.git] / libempathy / Makefile.am
index 98349b205dfe21b83ebc6fd2af7cc8c74c86effb..684d4e64b65cc6151716b13e3d38fb88d1de4e97 100644 (file)
@@ -1,12 +1,11 @@
 AM_CPPFLAGS =                                           \
+       -I.                                             \
+       -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
        $(WARN_CFLAGS)
 
-AM_LDFLAGS =                                           \
-       $(LIBEMPATHY_LIBS)
-
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
        empathy-marshal.c                               \
@@ -27,10 +26,16 @@ libempathy_la_SOURCES =                                                             \
        gossip-message.c                gossip-message.h                        \
        empathy-contact-list.c          empathy-contact-list.h                  \
        empathy-contact-manager.c       empathy-contact-manager.h               \
+       empathy-tp-contact-list.c       empathy-tp-contact-list.h               \
        empathy-tp-chat.c               empathy-tp-chat.h                       \
+       empathy-tp-chatroom.c           empathy-tp-chatroom.h                   \
        empathy-chandler.c              empathy-chandler.h                      \
+       empathy-idle.c                  empathy-idle.h                          \
        empathy-marshal-main.c
 
+libempathy_la_LIBADD =         \
+       $(LIBEMPATHY_LIBS)
+
 libempathy_includedir = $(includedir)/empathy/
 
 %-marshal.h: %-marshal.list Makefile.am