]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Merge remote-tracking branch 'origin/gnome-3-8'
[empathy.git] / libempathy / Makefile.am
index 67e64a9f60a5dc82f752afc534328df7f9adb31a..5f4059f20b88a978d40b00d2be9d92d32bbe3364 100644 (file)
@@ -2,8 +2,7 @@ include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        $(ERROR_CFLAGS)                                 \
-       -I.                                             \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/extensions                      \
        -I$(top_builddir)                               \
        -DDATADIR=\""$(datadir)"\"                      \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
@@ -16,10 +15,13 @@ AM_CPPFLAGS =                                           \
        $(CONNMAN_CFLAGS)                               \
        $(UDEV_CFLAGS)                                  \
        $(GOA_CFLAGS)                                   \
+       $(UOA_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
+       empathy-dtd-resources.c                         \
+       empathy-dtd-resources.h                         \
        empathy-enum-types.h                            \
        empathy-enum-types.c
 
@@ -99,6 +101,14 @@ goa_sources = \
        empathy-goa-auth-handler.h \
        $(NULL)
 
+# these are sources that depend on Ubuntu Online Accounts
+uoa_sources = \
+       empathy-uoa-auth-handler.c \
+       empathy-uoa-auth-handler.h \
+       empathy-uoa-utils.c \
+       empathy-uoa-utils.h \
+       $(NULL)
+
 pkglib_LTLIBRARIES = libempathy.la
 
 # libempathy's API is not stable and will never be, so use -release to make the
@@ -122,10 +132,10 @@ libempathy_la_LIBADD =            \
        $(CONNMAN_LIBS) \
        $(UDEV_LIBS) \
        $(GOA_LIBS) \
+       $(UOA_LIBS) \
        $(LIBM)
 
-dtddir = $(datadir)/empathy
-dtd_DATA =                                     \
+dtd_resources_files =                          \
        empathy-status-presets.dtd              \
        empathy-contact-groups.dtd              \
        empathy-chatroom-manager.dtd            \
@@ -135,8 +145,17 @@ ircnetworksdir = $(datadir)/empathy
 ircnetworks_DATA =             \
        irc-networks.xml
 
-EXTRA_DIST =                   \
-       $(dtd_DATA)             \
+dtd_resource_files: $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/empathy-dtd.gresource.xml)
+
+empathy-dtd-resources.c: empathy-dtd.gresource.xml $(dtd_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-dtd-resources.h: empathy-dtd.gresource.xml $(dtd_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
+
+EXTRA_DIST =                           \
+       empathy-dtd.gresource.xml       \
+       $(dtd_resources_files)          \
        $(ircnetworks_DATA)
 
 CLEANFILES =                           \
@@ -149,6 +168,12 @@ else
 EXTRA_DIST += $(goa_sources)
 endif
 
+if HAVE_UOA
+libempathy_la_SOURCES += $(uoa_sources)
+else
+EXTRA_DIST += $(uoa_sources)
+endif
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
@@ -156,6 +181,7 @@ nodist_libempathy_la_SOURCES =\
 check_c_sources = \
     $(libempathy_handwritten_source) \
     $(goa_sources) \
+    $(uoa_sources) \
     $(NULL)
 
 include $(top_srcdir)/tools/check-coding-style.mk
@@ -172,7 +198,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
                        --fhead "G_BEGIN_DECLS\n\n" \
                        --ftail "G_END_DECLS\n\n" \
                        --ftail "#endif /* __LIBEMPATHY_ENUM_TYPES_H__ */\n" \
-                       --fprod "#include <libempathy/@filename@>\n" \
+                       --fprod '#include "@filename@"\n' \
                        --eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
                        --eprod "GType @enum_name@_get_type (void);\n" \
                $(libempathy_headers) ) > xgen-gth \