]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Add CheeseCameraDeviceMonitor from libcheese
[empathy.git] / libempathy / Makefile.am
index 56ea9e780b8f2a20c68e36d9465a480bf3957eab..460026e53ea0d2ac85720c950bec73d3a5f939d2 100644 (file)
@@ -68,7 +68,7 @@ libempathy_headers =                          \
        empathy-types.h                         \
        empathy-utils.h
 
-libempathy_la_SOURCES =                                        \
+libempathy_handwritten_source =                                \
        $(libempathy_headers)                           \
        action-chain.c                                  \
        empathy-account-settings.c                      \
@@ -107,6 +107,10 @@ libempathy_la_SOURCES =                                    \
        empathy-tp-streamed-media.c                     \
        empathy-utils.c
 
+libempathy_la_SOURCES = \
+       $(libempathy_handwritten_source) \
+       cheese-camera-device-monitor.c cheese-camera-device-monitor.h
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
@@ -122,8 +126,7 @@ libempathy_la_LIBADD =              \
        $(CONNMAN_LIBS)
 
 check_c_sources = \
-    $(libempathy_la_SOURCES) \
-    $(libempathy_headers)
+    $(libempathy_handwritten_source)
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style