]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Move avatar cache to ~/.cache and don't mix avatar from different contacts, tokens...
[empathy.git] / libempathy / Makefile.am
index 1f79378d2b2a7f56817e1127dbddfcffa0012b00..3fb491855240cb81b97a3b967235e921c3d36bd0 100644 (file)
@@ -11,14 +11,11 @@ BUILT_SOURCES =                                     \
        empathy-marshal.c                               \
        empathy-marshal.list                            \
        empathy-enum-types.h                            \
-       empathy-enum-types.c                            \
-       empathy-filter-glue.h                           \
-       empathy-chandler-glue.h
+       empathy-enum-types.c
 
 lib_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                        \
-       empathy-avatar.c                                \
        empathy-time.c                                  \
        empathy-status-presets.c                        \
        empathy-debug.c                                 \
@@ -37,13 +34,14 @@ libempathy_la_SOURCES =                                     \
        empathy-tp-chat.c                               \
        empathy-tp-roomlist.c                           \
        empathy-tp-call.c                               \
-       empathy-chandler.c                              \
-       empathy-filter.c                                \
+       empathy-tp-tube.c                               \
        empathy-idle.c                                  \
        empathy-log-manager.c                           \
        empathy-irc-network-manager.c                   \
        empathy-irc-network.c                           \
-       empathy-irc-server.c
+       empathy-irc-server.c                            \
+       empathy-tube-handler.c                          \
+       empathy-dispatcher.c
 
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
@@ -58,7 +56,6 @@ libempathy_la_LDFLAGS =               \
        -export-symbols-regex ^empathy_
 
 libempathy_headers =                           \
-       empathy-avatar.h                        \
        empathy-time.h                          \
        empathy-status-presets.h                \
        empathy-debug.h                         \
@@ -77,13 +74,14 @@ libempathy_headers =                                \
        empathy-tp-chat.h                       \
        empathy-tp-roomlist.h                   \
        empathy-tp-call.h                       \
-       empathy-chandler.h                      \
-       empathy-filter.h                        \
+       empathy-tp-tube.h                       \
        empathy-idle.h                          \
        empathy-log-manager.h                   \
        empathy-irc-network-manager.h           \
        empathy-irc-network.h                   \
-       empathy-irc-server.h
+       empathy-irc-server.h                    \
+       empathy-tube-handler.h                  \
+       empathy-dispatcher.h
 
 libempathy_includedir = $(includedir)/libempathy/
 libempathy_include_HEADERS =                   \