]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Use double quotes for all internal headers
[empathy.git] / libempathy / Makefile.am
index ab7de6825e80c3c888e7e7cdc4984ab48443f15d..1cbd661c76207b3ba3b571987a91b26e39b400e2 100644 (file)
@@ -16,15 +16,16 @@ AM_CPPFLAGS =                                           \
        $(CONNMAN_CFLAGS)                               \
        $(UDEV_CFLAGS)                                  \
        $(GOA_CFLAGS)                                   \
+       $(UOA_CFLAGS)                                   \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
+       empathy-dtd-resources.c                         \
+       empathy-dtd-resources.h                         \
        empathy-enum-types.h                            \
        empathy-enum-types.c
 
-noinst_LTLIBRARIES = libempathy.la
-
 libempathy_headers =                           \
        action-chain-internal.h                 \
        empathy-account-settings.h              \
@@ -51,6 +52,7 @@ libempathy_headers =                          \
        empathy-message.h                       \
        empathy-pkg-kit.h               \
        empathy-request-util.h                  \
+       empathy-sasl-mechanisms.h               \
        empathy-server-sasl-handler.h           \
        empathy-server-tls-handler.h            \
        empathy-status-presets.h                \
@@ -85,6 +87,7 @@ libempathy_handwritten_source =                               \
        empathy-message.c                               \
        empathy-pkg-kit.c               \
        empathy-request-util.c                          \
+       empathy-sasl-mechanisms.c                       \
        empathy-server-sasl-handler.c                   \
        empathy-server-tls-handler.c                    \
        empathy-status-presets.c                        \
@@ -99,12 +102,41 @@ goa_sources = \
        empathy-goa-auth-handler.h \
        $(NULL)
 
+# these are sources that depend on Ubuntu Online Accounts
+uoa_sources = \
+       empathy-uoa-auth-handler.c \
+       empathy-uoa-auth-handler.h \
+       empathy-uoa-utils.c \
+       empathy-uoa-utils.h \
+       $(NULL)
+
+pkglib_LTLIBRARIES = libempathy.la
+
+# libempathy's API is not stable and will never be, so use -release to make the
+# SONAME of the plugin library change with every Empathy release.
+libempathy_la_LDFLAGS = \
+   -no-undefined \
+   -release $(VERSION) \
+   $(NULL)
+
 libempathy_la_SOURCES = \
        $(libempathy_handwritten_source) \
        cheese-camera-device-monitor.c cheese-camera-device-monitor.h
 
-dtddir = $(datadir)/empathy
-dtd_DATA =                                     \
+libempathy_la_LIBADD =         \
+       $(top_builddir)/extensions/libemp-extensions.la \
+       $(GCR_LIBS) \
+       $(EMPATHY_LIBS) \
+       $(GEOCLUE_LIBS) \
+       $(GEOCODE_LIBS) \
+       $(NETWORK_MANAGER_LIBS) \
+       $(CONNMAN_LIBS) \
+       $(UDEV_LIBS) \
+       $(GOA_LIBS) \
+       $(UOA_LIBS) \
+       $(LIBM)
+
+dtd_resources_files =                          \
        empathy-status-presets.dtd              \
        empathy-contact-groups.dtd              \
        empathy-chatroom-manager.dtd            \
@@ -114,8 +146,17 @@ ircnetworksdir = $(datadir)/empathy
 ircnetworks_DATA =             \
        irc-networks.xml
 
-EXTRA_DIST =                   \
-       $(dtd_DATA)             \
+dtd_resource_files: $(shell $(GLIB_COMPILE_RESOURCES) --sourcedir=$(srcdir) --generate-dependencies $(srcdir)/empathy-dtd.gresource.xml)
+
+empathy-dtd-resources.c: empathy-dtd.gresource.xml $(dtd_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-dtd-resources.h: empathy-dtd.gresource.xml $(dtd_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
+
+EXTRA_DIST =                           \
+       empathy-dtd.gresource.xml       \
+       $(dtd_resources_files)          \
        $(ircnetworks_DATA)
 
 CLEANFILES =                           \
@@ -128,25 +169,20 @@ else
 EXTRA_DIST += $(goa_sources)
 endif
 
+if HAVE_UOA
+libempathy_la_SOURCES += $(uoa_sources)
+else
+EXTRA_DIST += $(uoa_sources)
+endif
+
 # do not distribute generated files
 nodist_libempathy_la_SOURCES =\
        $(BUILT_SOURCES)
 
-libempathy_la_LIBADD =         \
-       $(top_builddir)/extensions/libemp-extensions.la \
-       $(GCR_LIBS) \
-       $(EMPATHY_LIBS) \
-       $(GEOCLUE_LIBS) \
-       $(GEOCODE_LIBS) \
-       $(NETWORK_MANAGER_LIBS) \
-       $(CONNMAN_LIBS) \
-       $(UDEV_LIBS) \
-       $(GOA_LIBS) \
-       $(LIBM)
-
 check_c_sources = \
     $(libempathy_handwritten_source) \
     $(goa_sources) \
+    $(uoa_sources) \
     $(NULL)
 
 include $(top_srcdir)/tools/check-coding-style.mk
@@ -163,7 +199,7 @@ stamp-empathy-enum-types.h: $(libempathy_headers) Makefile
                        --fhead "G_BEGIN_DECLS\n\n" \
                        --ftail "G_END_DECLS\n\n" \
                        --ftail "#endif /* __LIBEMPATHY_ENUM_TYPES_H__ */\n" \
-                       --fprod "#include <libempathy/@filename@>\n" \
+                       --fprod '#include "libempathy/@filename@"\n' \
                        --eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
                        --eprod "GType @enum_name@_get_type (void);\n" \
                $(libempathy_headers) ) > xgen-gth \