]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
add myself to AUTHORS
[empathy.git] / libempathy / Makefile.am
index 6a42bba9a9720a61037a24ce33637cb1d881278f..0ccd2deabf2be9da38841b5689de755a92372177 100644 (file)
@@ -2,6 +2,7 @@ include $(top_srcdir)/tools/shave.mk
 include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
+       $(ERROR_CFLAGS)                                 \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -I$(top_builddir)                               \
@@ -10,6 +11,8 @@ AM_CPPFLAGS =                                           \
        -DG_LOG_DOMAIN=\"empathy\"                      \
        $(LIBEMPATHY_CFLAGS)                            \
        $(GEOCLUE_CFLAGS)                               \
+       $(NETWORK_MANAGER_CFLAGS)                       \
+       $(CONNMAN_CFLAGS)                               \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -20,31 +23,77 @@ BUILT_SOURCES =                                     \
        empathy-enum-types.h                            \
        empathy-enum-types.c
 
-lib_LTLIBRARIES = libempathy.la
+noinst_LTLIBRARIES = libempathy.la
+
+libempathy_headers =                           \
+       empathy-account-settings.h              \
+       empathy-call-factory.h                  \
+       empathy-call-handler.h                  \
+       empathy-chatroom-manager.h              \
+       empathy-chatroom.h                      \
+       empathy-connection-managers.h           \
+       empathy-connectivity.h                  \
+       empathy-contact-groups.h                \
+       empathy-contact-list.h                  \
+       empathy-contact-manager.h               \
+       empathy-contact-monitor.h               \
+       empathy-contact.h                       \
+       empathy-debug.h                         \
+       empathy-debugger.h                      \
+       empathy-dispatch-operation.h            \
+       empathy-dispatcher.h                    \
+       empathy-ft-factory.h                    \
+       empathy-ft-handler.h                    \
+       empathy-handler.h                       \
+       empathy-idle.h                          \
+       empathy-irc-network-manager.h           \
+       empathy-irc-network.h                   \
+       empathy-irc-server.h                    \
+       empathy-location.h                      \
+       empathy-log-manager.h                   \
+       empathy-log-store-empathy.h             \
+       empathy-log-store.h                     \
+       empathy-message.h                       \
+       empathy-status-presets.h                \
+       empathy-time.h                          \
+       empathy-tp-call.h                       \
+       empathy-tp-chat.h                       \
+       empathy-tp-contact-factory.h            \
+       empathy-tp-contact-list.h               \
+       empathy-tp-file.h                       \
+       empathy-tp-roomlist.h                   \
+       empathy-tube-handler.h                  \
+       empathy-types.h                         \
+       empathy-utils.h
 
 libempathy_la_SOURCES =                                        \
-       empathy-account-manager.c                       \
-       empathy-chatroom.c                              \
-       empathy-chatroom-manager.c                      \
+       $(libempathy_headers)                           \
+       empathy-account-settings.c                      \
        empathy-call-factory.c                          \
        empathy-call-handler.c                          \
-       empathy-contact.c                               \
+       empathy-chatroom-manager.c                      \
+       empathy-chatroom.c                              \
+       empathy-connection-managers.c                   \
+       empathy-connectivity.c                          \
        empathy-contact-groups.c                        \
        empathy-contact-list.c                          \
        empathy-contact-manager.c                       \
        empathy-contact-monitor.c                       \
+       empathy-contact.c                               \
        empathy-debug.c                                 \
-       empathy-dispatcher.c                            \
+       empathy-debugger.c                              \
        empathy-dispatch-operation.c                    \
+       empathy-dispatcher.c                            \
        empathy-ft-factory.c                            \
        empathy-ft-handler.c                            \
+       empathy-handler.c                               \
        empathy-idle.c                                  \
-       empathy-irc-network.c                           \
        empathy-irc-network-manager.c                   \
+       empathy-irc-network.c                           \
        empathy-irc-server.c                            \
        empathy-log-manager.c                           \
-       empathy-log-store.c                             \
        empathy-log-store-empathy.c                     \
+       empathy-log-store.c                             \
        empathy-message.c                               \
        empathy-status-presets.c                        \
        empathy-time.c                                  \
@@ -64,48 +113,9 @@ nodist_libempathy_la_SOURCES =\
 libempathy_la_LIBADD =         \
        $(top_builddir)/extensions/libemp-extensions.la \
        $(LIBEMPATHY_LIBS) \
-       $(GEOCLUE_LIBS)
-
-libempathy_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_CURRENT}:${LIBEMPATHY_REVISION}:${LIBEMPATHY_AGE} \
-       -export-symbols-regex ^empathy_
-
-libempathy_headers =                           \
-       empathy-account-manager.h               \
-       empathy-chatroom.h                      \
-       empathy-chatroom-manager.h              \
-       empathy-call-factory.h                  \
-       empathy-call-handler.h                  \
-       empathy-contact.h                       \
-       empathy-contact-groups.h                \
-       empathy-contact-list.h                  \
-       empathy-contact-manager.h               \
-       empathy-contact-monitor.h               \
-       empathy-debug.h                         \
-       empathy-dispatcher.h                    \
-       empathy-dispatch-operation.h            \
-       empathy-ft-factory.h                    \
-       empathy-ft-handler.h                    \
-       empathy-idle.h                          \
-       empathy-irc-network.h                   \
-       empathy-irc-network-manager.h           \
-       empathy-irc-server.h                    \
-       empathy-location.h                      \
-       empathy-log-manager.h                   \
-       empathy-log-store.h                     \
-       empathy-log-store-empathy.h             \
-       empathy-message.h                       \
-       empathy-status-presets.h                \
-       empathy-time.h                          \
-       empathy-tp-call.h                       \
-       empathy-tp-chat.h                       \
-       empathy-tp-contact-factory.h            \
-       empathy-tp-contact-list.h               \
-       empathy-tp-file.h                       \
-       empathy-tp-roomlist.h                   \
-       empathy-tube-handler.h                  \
-       empathy-types.h                         \
-       empathy-utils.h
+       $(GEOCLUE_LIBS) \
+       $(NETWORK_MANAGER_LIBS) \
+       $(CONNMAN_LIBS)
 
 check_c_sources = \
     $(libempathy_la_SOURCES) \
@@ -113,11 +123,6 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-libempathy_includedir = $(includedir)/libempathy/
-libempathy_include_HEADERS =                   \
-       $(libempathy_headers)                   \
-       empathy-enum-types.h
-
 empathy-marshal.list: $(libempathy_la_SOURCES) Makefile.am
        $(QUIET_GEN)( cd $(srcdir) && \
        sed -n -e 's/.*empathy_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
@@ -189,9 +194,6 @@ ircnetworksdir = $(datadir)/empathy
 ircnetworks_DATA =             \
        irc-networks.xml
 
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libempathy.pc
-
 EXTRA_DIST =                   \
        empathy-marshal.list    \
        $(stylesheet_DATA)      \