]> git.0d.be Git - empathy.git/blobdiff - libempathy/Makefile.am
Rename all filenames starting with "gossip" by "empathy", change namespace
[empathy.git] / libempathy / Makefile.am
index 98349b205dfe21b83ebc6fd2af7cc8c74c86effb..00ce4233af9b703363b4e693bf2c57db6e9e9d2f 100644 (file)
@@ -1,12 +1,10 @@
 AM_CPPFLAGS =                                           \
+       -I.                                             \
+       -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
-       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(LIBEMPATHY_CFLAGS)                            \
        $(WARN_CFLAGS)
 
-AM_LDFLAGS =                                           \
-       $(LIBEMPATHY_LIBS)
-
 BUILT_SOURCES =                                        \
        empathy-marshal.h                               \
        empathy-marshal.c                               \
@@ -15,22 +13,30 @@ BUILT_SOURCES =                                     \
 noinst_LTLIBRARIES = libempathy.la
 
 libempathy_la_SOURCES =                                                        \
-       gossip-conf.c                   gossip-conf.h                           \
-       gossip-contact.c                gossip-contact.h                        \
-       gossip-avatar.c                 gossip-avatar.h                         \
-       gossip-time.c                   gossip-time.h                           \
-       gossip-presence.c               gossip-presence.h                       \
-       gossip-telepathy-group.c        gossip-telepathy-group.h                \
-       gossip-paths.c                  gossip-paths.h                          \
-       gossip-debug.c                  gossip-debug.h                          \
-       gossip-utils.c                  gossip-utils.h                          \
-       gossip-message.c                gossip-message.h                        \
+       empathy-conf.c                  empathy-conf.h                          \
+       empathy-contact.c               empathy-contact.h                       \
+       empathy-avatar.c                empathy-avatar.h                        \
+       empathy-time.c                  empathy-time.h                          \
+       empathy-presence.c              empathy-presence.h                      \
+       empathy-debug.c                 empathy-debug.h                         \
+       empathy-utils.c                 empathy-utils.h                         \
+       empathy-message.c               empathy-message.h                       \
+       empathy-chatroom-manager.c      empathy-chatroom-manager.h              \
+       empathy-chatroom.c              empathy-chatroom.h                      \
        empathy-contact-list.c          empathy-contact-list.h                  \
        empathy-contact-manager.c       empathy-contact-manager.h               \
+       empathy-tp-group.c              empathy-tp-group.h                      \
+       empathy-tp-contact-list.c       empathy-tp-contact-list.h               \
        empathy-tp-chat.c               empathy-tp-chat.h                       \
+       empathy-tp-chatroom.c           empathy-tp-chatroom.h                   \
        empathy-chandler.c              empathy-chandler.h                      \
+       empathy-idle.c                  empathy-idle.h                          \
+       empathy-log-manager.c           empathy-log-manager.h                   \
        empathy-marshal-main.c
 
+libempathy_la_LIBADD =         \
+       $(LIBEMPATHY_LIBS)
+
 libempathy_includedir = $(includedir)/empathy/
 
 %-marshal.h: %-marshal.list Makefile.am
@@ -44,8 +50,18 @@ libempathy_includedir = $(includedir)/empathy/
 empathy-chandler-glue.h: empathy-chandler.xml
        $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_chandler --mode=glib-server --output=$@ $<
 
+dtddir = $(datadir)/empathy
+dtd_DATA =                                     \
+       empathy-chatroom-manager.dtd
+
+stylesheetdir = $(datadir)/empathy
+stylesheet_DATA =              \
+       empathy-log-manager.xsl
+
 EXTRA_DIST =                   \
        empathy-marshal.list    \
-       empathy-chandler.xml
+       empathy-chandler.xml    \
+       $(stylesheet_DATA)      \
+       $(dtd_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)