]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
add myself to AUTHORS
[empathy.git] / libempathy-gtk / Makefile.am
index 999e565a5f3e5725b528d06e75acbed7422eb184..ce2f3ba97aac00122a3e40331f4be133de76f24d 100644 (file)
@@ -1,14 +1,19 @@
 include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
+       $(ERROR_CFLAGS)                                 \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(LIBEMPATHYGTK_CFLAGS)                         \
+       $(LIBNOTIFY_CFLAGS)                             \
        $(ENCHANT_CFLAGS)                               \
        $(LIBCHAMPLAIN_CFLAGS)                          \
        $(GEOCLUE_CFLAGS)                               \
+       $(MOBLIN_CFLAGS)                                \
+       $(WEBKIT_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -19,21 +24,24 @@ BUILT_SOURCES =                                     \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
-lib_LTLIBRARIES = libempathy-gtk.la
+noinst_LTLIBRARIES = libempathy-gtk.la
 
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
-       empathy-account-widget.c                \
        empathy-account-widget-irc.c            \
+       empathy-account-widget-private.h        \
        empathy-account-widget-sip.c            \
+       empathy-account-widget.c                \
+       empathy-audio-sink.c                    \
+       empathy-audio-src.c                     \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
        empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-chat.c                          \
        empathy-chat-text-view.c                \
        empathy-chat-view.c                     \
+       empathy-chat.c                          \
        empathy-conf.c                          \
        empathy-contact-dialogs.c               \
        empathy-contact-list-store.c            \
@@ -42,55 +50,40 @@ libempathy_gtk_handwritten_source =                 \
        empathy-contact-selector.c              \
        empathy-contact-widget.c                \
        empathy-geometry.c                      \
-       empathy-audio-sink.c                    \
-       empathy-audio-src.c                     \
-       empathy-video-src.c                     \
-       empathy-video-widget.c                  \
        empathy-irc-network-dialog.c            \
+       empathy-kludge-label.c                  \
        empathy-log-window.c                    \
        empathy-new-message-dialog.c            \
+       empathy-notify-manager.c                \
        empathy-presence-chooser.c              \
-       empathy-profile-chooser.c               \
+       empathy-protocol-chooser.c              \
+       empathy-share-my-desktop.c              \
        empathy-smiley-manager.c                \
+       empathy-sound.c                         \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
        empathy-theme-boxes.c                   \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
-       empathy-ui-utils.c
-
-libempathy_gtk_la_SOURCES =                    \
-       $(libempathy_gtk_handwritten_source)    \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
-
-# do not distribute generated files
-nodist_libempathy_gtk_la_SOURCES =\
-       $(BUILT_SOURCES)
-
-libempathy_gtk_la_LIBADD =                     \
-       $(LIBEMPATHYGTK_LIBS)                   \
-       $(ENCHANT_LIBS)                         \
-       $(LIBCHAMPLAIN_LIBS)                    \
-       $(GEOCLUE_LIBS)                         \
-       $(top_builddir)/libempathy/libempathy.la
-
-libempathy_gtk_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_GTK_CURRENT}:${LIBEMPATHY_GTK_REVISION}:${LIBEMPATHY_GTK_AGE} \
-       -export-symbols-regex ^empathy_
+       empathy-ui-utils.c                      \
+       empathy-video-src.c                     \
+       empathy-video-widget.c
 
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
-       empathy-account-widget.h                \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
+       empathy-account-widget.h                \
+       empathy-audio-sink.h                    \
+       empathy-audio-src.h                     \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
        empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-chat.h                          \
        empathy-chat-text-view.h                \
        empathy-chat-view.h                     \
+       empathy-chat.h                          \
        empathy-conf.h                          \
        empathy-contact-dialogs.h               \
        empathy-contact-list-store.h            \
@@ -99,23 +92,44 @@ libempathy_gtk_headers =                    \
        empathy-contact-selector.h              \
        empathy-contact-widget.h                \
        empathy-geometry.h                      \
-       empathy-audio-sink.h                    \
-       empathy-audio-src.h                     \
-       empathy-video-src.h                     \
-       empathy-video-widget.h                  \
        empathy-images.h                        \
        empathy-irc-network-dialog.h            \
+       empathy-kludge-label.h                  \
        empathy-log-window.h                    \
        empathy-new-message-dialog.h            \
+       empathy-notify-manager.h                \
        empathy-presence-chooser.h              \
-       empathy-profile-chooser.h               \
+       empathy-protocol-chooser.h              \
+       empathy-share-my-desktop.h              \
        empathy-smiley-manager.h                \
+       empathy-sound.h                         \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
        empathy-theme-boxes.h                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
-       empathy-ui-utils.h
+       empathy-ui-utils.h                      \
+       empathy-video-src.h                     \
+       empathy-video-widget.h
+
+libempathy_gtk_la_SOURCES =                    \
+       $(libempathy_gtk_handwritten_source)    \
+       $(libempathy_gtk_headers)               \
+       totem-subtitle-encoding.c totem-subtitle-encoding.h
+
+# do not distribute generated files
+nodist_libempathy_gtk_la_SOURCES =\
+       $(BUILT_SOURCES)
+
+libempathy_gtk_la_LIBADD =                     \
+       $(LIBEMPATHYGTK_LIBS)                   \
+       $(LIBNOTIFY_LIBS)                       \
+       $(ENCHANT_LIBS)                         \
+       $(LIBCHAMPLAIN_LIBS)                    \
+       $(GEOCLUE_LIBS)                         \
+       $(MOBLIN_LIBS)                          \
+       $(WEBKIT_LIBS)                          \
+       $(top_builddir)/libempathy/libempathy.la
 
 check_c_sources = \
     $(libempathy_gtk_handwritten_source) \
@@ -123,11 +137,6 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-libempathy_gtk_includedir = $(includedir)/libempathy-gtk/
-libempathy_gtk_include_HEADERS =               \
-       $(libempathy_gtk_headers)               \
-       empathy-gtk-enum-types.h
-
 uidir = $(datadir)/empathy
 ui_DATA =                                      \
        empathy-contact-widget.ui               \
@@ -136,7 +145,7 @@ ui_DATA =                                   \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
        empathy-account-widget-sip.ui           \
-       empathy-account-widget-salut.ui         \
+       empathy-account-widget-local-xmpp.ui    \
        empathy-account-widget-irc.ui           \
        empathy-account-widget-icq.ui           \
        empathy-account-widget-yahoo.ui         \
@@ -203,12 +212,36 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libempathy-gtk.pc
-
 EXTRA_DIST =                   \
        $(ui_DATA)
 
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source +=           \
+       empathy-location-manager.c
+
+libempathy_gtk_headers +=                      \
+       empathy-location-manager.h
+else
+EXTRA_DIST +=                                  \
+       empathy-location-manager.c              \
+       empathy-location-manager.h
+endif
+
+if HAVE_WEBKIT
+libempathy_gtk_handwritten_source +=           \
+       empathy-plist.c                         \
+       empathy-theme-adium.c
+libempathy_gtk_headers +=                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h
+else
+EXTRA_DIST +=                                  \
+       empathy-plist.c                         \
+       empathy-plist.h                         \
+       empathy-theme-adium.c                   \
+       empathy-theme-adium.h
+endif
+
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h