]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Merge branch 'sjoerd-mc5' into mc5
[empathy.git] / libempathy-gtk / Makefile.am
index cf6a2762fa10a36421f1919f5f3234035f0088a6..70e11e4128384a1e949cf6713ebe6182e9dc1814 100644 (file)
@@ -1,4 +1,5 @@
 include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        -I.                                             \
@@ -7,6 +8,9 @@ AM_CPPFLAGS =                                           \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(LIBEMPATHYGTK_CFLAGS)                         \
        $(ENCHANT_CFLAGS)                               \
+       $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(GEOCLUE_CFLAGS)                               \
+       $(WEBKIT_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -37,6 +41,7 @@ libempathy_gtk_handwritten_source =                   \
        empathy-contact-list-store.c            \
        empathy-contact-list-view.c             \
        empathy-contact-menu.c                  \
+       empathy-share-my-desktop.c              \
        empathy-contact-selector.c              \
        empathy-contact-widget.c                \
        empathy-geometry.c                      \
@@ -48,13 +53,15 @@ libempathy_gtk_handwritten_source =                 \
        empathy-log-window.c                    \
        empathy-new-message-dialog.c            \
        empathy-presence-chooser.c              \
-       empathy-profile-chooser.c               \
+       empathy-protocol-chooser.c              \
        empathy-smiley-manager.c                \
+       empathy-sound.c                         \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
        empathy-theme-boxes.c                   \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
+       empathy-kludge-label.c                  \
        empathy-ui-utils.c
 
 libempathy_gtk_la_SOURCES =                    \
@@ -63,11 +70,15 @@ libempathy_gtk_la_SOURCES =                 \
 
 # do not distribute generated files
 nodist_libempathy_gtk_la_SOURCES =\
+       empathy-account-widget-private.h        \
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
        $(LIBEMPATHYGTK_LIBS)                   \
        $(ENCHANT_LIBS)                         \
+       $(LIBCHAMPLAIN_LIBS)                    \
+       $(GEOCLUE_LIBS)                         \
+       $(WEBKIT_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
 libempathy_gtk_la_LDFLAGS =                \
@@ -92,6 +103,7 @@ libempathy_gtk_headers =                     \
        empathy-contact-list-store.h            \
        empathy-contact-list-view.h             \
        empathy-contact-menu.h                  \
+       empathy-share-my-desktop.h              \
        empathy-contact-selector.h              \
        empathy-contact-widget.h                \
        empathy-geometry.h                      \
@@ -104,13 +116,15 @@ libempathy_gtk_headers =                  \
        empathy-log-window.h                    \
        empathy-new-message-dialog.h            \
        empathy-presence-chooser.h              \
-       empathy-profile-chooser.h               \
+       empathy-protocol-chooser.h              \
        empathy-smiley-manager.h                \
+       empathy-sound.h                         \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
        empathy-theme-boxes.h                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
+       empathy-kludge-label.h                  \
        empathy-ui-utils.h
 
 check_c_sources = \
@@ -132,7 +146,7 @@ ui_DATA =                                   \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
        empathy-account-widget-sip.ui           \
-       empathy-account-widget-salut.ui         \
+       empathy-account-widget-local-xmpp.ui    \
        empathy-account-widget-irc.ui           \
        empathy-account-widget-icq.ui           \
        empathy-account-widget-yahoo.ui         \
@@ -205,6 +219,33 @@ pkgconfig_DATA = libempathy-gtk.pc
 EXTRA_DIST =                   \
        $(ui_DATA)
 
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source +=           \
+       empathy-location-manager.c
+
+libempathy_gtk_headers +=                      \
+       empathy-location-manager.h
+else
+EXTRA_DIST +=                                  \
+       empathy-location-manager.c              \
+       empathy-location-manager.h
+endif
+
+if HAVE_WEBKIT
+libempathy_gtk_handwritten_source +=           \
+       empathy-plist.c                         \
+       empathy-theme-adium.c
+libempathy_gtk_headers +=                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h
+else
+EXTRA_DIST +=                                  \
+       empathy-plist.c                         \
+       empathy-plist.h                         \
+       empathy-theme-adium.c                   \
+       empathy-theme-adium.h
+endif
+
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h