]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Merge commit 'jtellier/video-call-button-sensitivity'
[empathy.git] / libempathy-gtk / Makefile.am
index c4f07cf74919fc8f4278cfdb1216984fcc13b472..5903efb15daf37864c749eabfc63b6a43df7500a 100644 (file)
@@ -1,9 +1,18 @@
+include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
+
 AM_CPPFLAGS =                                           \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
-       $(EMPATHY_CFLAGS)                               \
-       $(WARN_CFLAGS)
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       $(LIBEMPATHYGTK_CFLAGS)                         \
+       $(ENCHANT_CFLAGS)                               \
+       $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(GEOCLUE_CFLAGS)                               \
+       $(WEBKIT_CFLAGS)                                \
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        empathy-gtk-marshal.h                           \
@@ -14,38 +23,48 @@ BUILT_SOURCES =                                     \
 
 lib_LTLIBRARIES = libempathy-gtk.la
 
-libempathy_gtk_la_SOURCES =                    \
+libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
-       empathy-chat.c                          \
-       empathy-irc-network-dialog.c            \
-       empathy-spell-dialog.c                  \
-       empathy-accounts-dialog.c               \
-       empathy-chat-view.c                     \
-       empathy-log-window.c                    \
-       empathy-theme-boxes.c                   \
        empathy-account-widget.c                \
-       empathy-conf.c                          \
-       empathy-theme.c                         \
        empathy-account-widget-irc.c            \
        empathy-account-widget-sip.c            \
-       empathy-contact-dialogs.c               \
-       empathy-new-message-dialog.c            \
-       empathy-theme-irc.c                     \
        empathy-avatar-chooser.c                \
-       empathy-contact-list-store.c            \
-       empathy-presence-chooser.c              \
-       empathy-theme-manager.c                 \
        empathy-avatar-image.c                  \
-       empathy-contact-list-view.c             \
-       empathy-ui-utils.c                      \
        empathy-cell-renderer-activatable.c     \
-       empathy-contact-widget.c                \
-       empathy-profile-chooser.c               \
        empathy-cell-renderer-expander.c        \
+       empathy-cell-renderer-text.c            \
+       empathy-chat.c                          \
+       empathy-chat-text-view.c                \
+       empathy-chat-view.c                     \
+       empathy-conf.c                          \
+       empathy-contact-dialogs.c               \
+       empathy-contact-list-store.c            \
+       empathy-contact-list-view.c             \
+       empathy-contact-menu.c                  \
+       empathy-contact-selector.c              \
+       empathy-contact-widget.c                \
        empathy-geometry.c                      \
+       empathy-audio-sink.c                    \
+       empathy-audio-src.c                     \
+       empathy-video-src.c                     \
+       empathy-video-widget.c                  \
+       empathy-irc-network-dialog.c            \
+       empathy-log-window.c                    \
+       empathy-new-message-dialog.c            \
+       empathy-presence-chooser.c              \
+       empathy-profile-chooser.c               \
        empathy-smiley-manager.c                \
-       empathy-cell-renderer-text.c            \
+       empathy-sound.c                         \
        empathy-spell.c                         \
+       empathy-status-preset-dialog.c          \
+       empathy-theme-boxes.c                   \
+       empathy-theme-irc.c                     \
+       empathy-theme-manager.c                 \
+       empathy-kludge-label.c                  \
+       empathy-ui-utils.c
+
+libempathy_gtk_la_SOURCES =                    \
+       $(libempathy_gtk_handwritten_source)    \
        totem-subtitle-encoding.c totem-subtitle-encoding.h
 
 # do not distribute generated files
@@ -53,7 +72,11 @@ nodist_libempathy_gtk_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
-       $(EMPATHY_LIBS)                         \
+       $(LIBEMPATHYGTK_LIBS)                   \
+       $(ENCHANT_LIBS)                         \
+       $(LIBCHAMPLAIN_LIBS)                    \
+       $(GEOCLUE_LIBS)                         \
+       $(WEBKIT_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
 libempathy_gtk_la_LDFLAGS =                \
@@ -61,67 +84,78 @@ libempathy_gtk_la_LDFLAGS =                \
        -export-symbols-regex ^empathy_
 
 libempathy_gtk_headers =                       \
-       empathy-images.h                        \
        empathy-account-chooser.h               \
-       empathy-chat.h                          \
-       empathy-irc-network-dialog.h            \
-       empathy-spell-dialog.h                  \
-       empathy-accounts-dialog.h               \
-       empathy-chat-view.h                     \
-       empathy-log-window.h                    \
-       empathy-theme-boxes.h                   \
        empathy-account-widget.h                \
-       empathy-conf.h                          \
-       empathy-theme.h                         \
        empathy-account-widget-irc.h            \
        empathy-account-widget-sip.h            \
-       empathy-contact-dialogs.h               \
-       empathy-new-message-dialog.h            \
-       empathy-theme-irc.h                     \
        empathy-avatar-chooser.h                \
-       empathy-contact-list-store.h            \
-       empathy-presence-chooser.h              \
-       empathy-theme-manager.h                 \
        empathy-avatar-image.h                  \
-       empathy-contact-list-view.h             \
-       empathy-ui-utils.h                      \
        empathy-cell-renderer-activatable.h     \
-       empathy-contact-widget.h                \
-       empathy-profile-chooser.h               \
        empathy-cell-renderer-expander.h        \
+       empathy-cell-renderer-text.h            \
+       empathy-chat.h                          \
+       empathy-chat-text-view.h                \
+       empathy-chat-view.h                     \
+       empathy-conf.h                          \
+       empathy-contact-dialogs.h               \
+       empathy-contact-list-store.h            \
+       empathy-contact-list-view.h             \
+       empathy-contact-menu.h                  \
+       empathy-contact-selector.h              \
+       empathy-contact-widget.h                \
        empathy-geometry.h                      \
+       empathy-audio-sink.h                    \
+       empathy-audio-src.h                     \
+       empathy-video-src.h                     \
+       empathy-video-widget.h                  \
+       empathy-images.h                        \
+       empathy-irc-network-dialog.h            \
+       empathy-log-window.h                    \
+       empathy-new-message-dialog.h            \
+       empathy-presence-chooser.h              \
+       empathy-profile-chooser.h               \
        empathy-smiley-manager.h                \
-       empathy-cell-renderer-text.h            \
-       empathy-spell.h
+       empathy-sound.h                         \
+       empathy-spell.h                         \
+       empathy-status-preset-dialog.h          \
+       empathy-theme-boxes.h                   \
+       empathy-theme-irc.h                     \
+       empathy-theme-manager.h                 \
+       empathy-kludge-label.h                  \
+       empathy-ui-utils.h
+
+check_c_sources = \
+    $(libempathy_gtk_handwritten_source) \
+    $(libempathy_gtk_headers)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
 
 libempathy_gtk_includedir = $(includedir)/libempathy-gtk/
 libempathy_gtk_include_HEADERS =               \
        $(libempathy_gtk_headers)               \
        empathy-gtk-enum-types.h
 
-gladedir = $(datadir)/empathy
-glade_DATA =                                   \
-       empathy-contact-widget.glade            \
-       empathy-contact-dialogs.glade           \
-       empathy-presence-chooser.glade          \
-       empathy-accounts-dialog.glade           \
-       empathy-account-widget-generic.glade    \
-       empathy-account-widget-jabber.glade     \
-       empathy-account-widget-msn.glade        \
-       empathy-account-widget-sip.glade        \
-       empathy-account-widget-salut.glade      \
-       empathy-account-widget-irc.glade        \
-       empathy-account-widget-icq.glade        \
-       empathy-account-widget-yahoo.glade      \
-       empathy-account-widget-groupwise.glade  \
-       empathy-account-widget-aim.glade        \
-       empathy-spell-dialog.glade              \
-       empathy-log-window.glade                \
-       empathy-chat.glade                      \
-       empathy-new-message-dialog.glade
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-contact-widget.ui               \
+       empathy-contact-dialogs.ui              \
+       empathy-account-widget-generic.ui       \
+       empathy-account-widget-jabber.ui        \
+       empathy-account-widget-msn.ui           \
+       empathy-account-widget-sip.ui           \
+       empathy-account-widget-salut.ui         \
+       empathy-account-widget-irc.ui           \
+       empathy-account-widget-icq.ui           \
+       empathy-account-widget-yahoo.ui         \
+       empathy-account-widget-groupwise.ui     \
+       empathy-account-widget-aim.ui           \
+       empathy-status-preset-dialog.ui         \
+       empathy-log-window.ui                   \
+       empathy-chat.ui                         \
+       empathy-new-message-dialog.ui
 
 empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
-       ( cd $(srcdir) && \
+       $(QUIET_GEN)( cd $(srcdir) && \
        sed -n -e 's/.*empathy_gtk_marshal_\([[:upper:][:digit:]]*__[[:upper:][:digit:]_]*\).*/\1/p' \
        $(libempathy_gtk_la_SOURCES) ) \
        | sed -e 's/__/:/' -e 'y/_/,/' | sort -u > $@.tmp
@@ -132,16 +166,16 @@ empathy-gtk-marshal.list: $(libempathy_gtk_la_SOURCES) Makefile.am
        fi
 
 %-marshal.h: %-marshal.list Makefile
-       $(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
+       $(QUIET_GEN)$(GLIB_GENMARSHAL) --header --prefix=_$(subst -,_,$*)_marshal $< > $*-marshal.h
 
 %-marshal.c: %-marshal.list Makefile
-       echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
+       $(QUIET_GEN)echo "#include \"empathy-gtk-marshal.h\"" > $@ && \
        $(GLIB_GENMARSHAL) --body --prefix=_$(subst -,_,$*)_marshal $< >> $*-marshal.c
 
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
-       @true
+       $(QUIET_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_GTK_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_GTK_ENUM_TYPES_H__ 1\n\n" \
@@ -158,7 +192,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
        && echo timestamp > $(@F)
 
 empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
-       (cd $(srcdir) \
+       $(QUIET_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -180,7 +214,34 @@ pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = libempathy-gtk.pc
 
 EXTRA_DIST =                   \
-       $(glade_DATA)
+       $(ui_DATA)
+
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source +=           \
+       empathy-location-manager.c
+
+libempathy_gtk_headers +=                      \
+       empathy-location-manager.h
+else
+EXTRA_DIST +=                                  \
+       empathy-location-manager.c              \
+       empathy-location-manager.h
+endif
+
+if HAVE_WEBKIT
+libempathy_gtk_handwritten_source +=           \
+       empathy-plist.c                         \
+       empathy-theme-adium.c
+libempathy_gtk_headers +=                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h
+else
+EXTRA_DIST +=                                  \
+       empathy-plist.c                         \
+       empathy-plist.h                         \
+       empathy-theme-adium.c                   \
+       empathy-theme-adium.h
+endif
 
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \