]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Merge commit 'jtellier/video-call-button-sensitivity'
[empathy.git] / libempathy-gtk / Makefile.am
index 210b6d4b041defa33d94008fb8fc08a863185917..5903efb15daf37864c749eabfc63b6a43df7500a 100644 (file)
@@ -1,4 +1,5 @@
 include $(top_srcdir)/tools/shave.mk
+include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        -I.                                             \
@@ -7,6 +8,9 @@ AM_CPPFLAGS =                                           \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(LIBEMPATHYGTK_CFLAGS)                         \
        $(ENCHANT_CFLAGS)                               \
+       $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(GEOCLUE_CFLAGS)                               \
+       $(WEBKIT_CFLAGS)                                \
        $(WARN_CFLAGS)                                  \
        $(DISABLE_DEPRECATED)
 
@@ -19,7 +23,7 @@ BUILT_SOURCES =                                       \
 
 lib_LTLIBRARIES = libempathy-gtk.la
 
-libempathy_gtk_la_SOURCES =                    \
+libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
        empathy-account-widget.c                \
        empathy-account-widget-irc.c            \
@@ -50,12 +54,17 @@ libempathy_gtk_la_SOURCES =                 \
        empathy-presence-chooser.c              \
        empathy-profile-chooser.c               \
        empathy-smiley-manager.c                \
+       empathy-sound.c                         \
        empathy-spell.c                         \
        empathy-status-preset-dialog.c          \
        empathy-theme-boxes.c                   \
        empathy-theme-irc.c                     \
        empathy-theme-manager.c                 \
-       empathy-ui-utils.c                      \
+       empathy-kludge-label.c                  \
+       empathy-ui-utils.c
+
+libempathy_gtk_la_SOURCES =                    \
+       $(libempathy_gtk_handwritten_source)    \
        totem-subtitle-encoding.c totem-subtitle-encoding.h
 
 # do not distribute generated files
@@ -65,6 +74,9 @@ nodist_libempathy_gtk_la_SOURCES =\
 libempathy_gtk_la_LIBADD =                     \
        $(LIBEMPATHYGTK_LIBS)                   \
        $(ENCHANT_LIBS)                         \
+       $(LIBCHAMPLAIN_LIBS)                    \
+       $(GEOCLUE_LIBS)                         \
+       $(WEBKIT_LIBS)                          \
        $(top_builddir)/libempathy/libempathy.la
 
 libempathy_gtk_la_LDFLAGS =                \
@@ -103,13 +115,21 @@ libempathy_gtk_headers =                  \
        empathy-presence-chooser.h              \
        empathy-profile-chooser.h               \
        empathy-smiley-manager.h                \
+       empathy-sound.h                         \
        empathy-spell.h                         \
        empathy-status-preset-dialog.h          \
        empathy-theme-boxes.h                   \
        empathy-theme-irc.h                     \
        empathy-theme-manager.h                 \
+       empathy-kludge-label.h                  \
        empathy-ui-utils.h
 
+check_c_sources = \
+    $(libempathy_gtk_handwritten_source) \
+    $(libempathy_gtk_headers)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
 libempathy_gtk_includedir = $(includedir)/libempathy-gtk/
 libempathy_gtk_include_HEADERS =               \
        $(libempathy_gtk_headers)               \
@@ -196,6 +216,33 @@ pkgconfig_DATA = libempathy-gtk.pc
 EXTRA_DIST =                   \
        $(ui_DATA)
 
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source +=           \
+       empathy-location-manager.c
+
+libempathy_gtk_headers +=                      \
+       empathy-location-manager.h
+else
+EXTRA_DIST +=                                  \
+       empathy-location-manager.c              \
+       empathy-location-manager.h
+endif
+
+if HAVE_WEBKIT
+libempathy_gtk_handwritten_source +=           \
+       empathy-plist.c                         \
+       empathy-theme-adium.c
+libempathy_gtk_headers +=                      \
+       empathy-plist.h                         \
+       empathy-theme-adium.h
+else
+EXTRA_DIST +=                                  \
+       empathy-plist.c                         \
+       empathy-plist.h                         \
+       empathy-theme-adium.c                   \
+       empathy-theme-adium.h
+endif
+
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \
        stamp-empathy-gtk-enum-types.h