]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
Use double quotes for all internal headers
[empathy.git] / libempathy-gtk / Makefile.am
index 59e495224b3afb413b5255821d36d36327b3af6e..4c8f54c1a4b5fba2e26bfa57b239504f6cc9917f 100644 (file)
@@ -22,6 +22,8 @@ AM_CPPFLAGS =                                           \
        $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
+       empathy-account-widgets-resources.c             \
+       empathy-account-widgets-resources.h             \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
@@ -77,6 +79,8 @@ libempathy_gtk_handwritten_source =                   \
        empathy-roster-contact.c                        \
        empathy-roster-group.c                  \
        empathy-roster-model.c                  \
+       empathy-roster-model-aggregator.c                       \
+       empathy-roster-model-manager.c                  \
        empathy-roster-view.c                   \
        empathy-search-bar.c                    \
        empathy-share-my-desktop.c              \
@@ -89,6 +93,7 @@ libempathy_gtk_handwritten_source =                   \
        empathy-theme-manager.c                 \
        empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
+       empathy-user-info.c                     \
        empathy-plist.c                         \
        empathy-theme-adium.c                   \
        empathy-webkit-utils.c                  \
@@ -146,6 +151,8 @@ libempathy_gtk_headers =                    \
        empathy-roster-contact.h                        \
        empathy-roster-group.h                  \
        empathy-roster-model.h                  \
+       empathy-roster-model-aggregator.h                       \
+       empathy-roster-model-manager.h                  \
        empathy-roster-view.h                   \
        empathy-search-bar.h                    \
        empathy-share-my-desktop.h              \
@@ -158,6 +165,7 @@ libempathy_gtk_headers =                    \
        empathy-theme-manager.h                 \
        empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
+       empathy-user-info.h                     \
        empathy-plist.h                         \
        empathy-theme-adium.h                   \
        empathy-webkit-utils.h                  \
@@ -203,10 +211,7 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-uidir = $(datadir)/empathy
-ui_DATA =                                      \
-       empathy-contact-widget.ui               \
-       empathy-contact-blocking-dialog.ui      \
+account_widgets_ui_files =                     \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -217,6 +222,12 @@ ui_DATA =                                  \
        empathy-account-widget-yahoo.ui         \
        empathy-account-widget-groupwise.ui     \
        empathy-account-widget-aim.ui           \
+       $(NULL)
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-contact-widget.ui               \
+       empathy-contact-blocking-dialog.ui      \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
@@ -234,7 +245,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
                        --fhead "G_BEGIN_DECLS\n\n" \
                        --ftail "G_END_DECLS\n\n" \
                        --ftail "#endif /* __LIBEMPATHY_GTK_ENUM_TYPES_H__ */\n" \
-                       --fprod "#include <libempathy-gtk/@filename@>\n" \
+                       --fprod '#include "libempathy-gtk/@filename@"\n' \
                        --eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
                        --eprod "GType @enum_name@_get_type (void);\n" \
                $(libempathy_gtk_headers) ) > xgen-gth \
@@ -261,7 +272,17 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-EXTRA_DIST =                   \
+account_widgets_resource_files = $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-account-widgets.gresource.xml)
+
+empathy-account-widgets-resources.c: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-account-widgets-resources.h: empathy-account-widgets.gresource.xml $(account_widgets_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<
+
+EXTRA_DIST =                                   \
+       empathy-account-widgets.gresource.xml   \
+       $(account_widgets_ui_files)             \
        $(ui_DATA)
 
 if HAVE_GEOCLUE