]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
tp-account-widgets: Move account widgets code in the tp-account-widgets subdir
[empathy.git] / libempathy-gtk / Makefile.am
index 902a5e57fe6b4128b1c9f257c2d5a9c5ce08d3bc..3605eea78be8fa24de66a173e5ec44db8be42a9d 100644 (file)
@@ -4,8 +4,9 @@ include $(top_srcdir)/tools/flymake.mk
 
 AM_CPPFLAGS =                                           \
        $(ERROR_CFLAGS)                                 \
-       -I.                                             \
-       -I$(top_srcdir)                                 \
+       -I$(top_srcdir)/tp-account-widgets              \
+       -I$(top_srcdir)/libempathy                      \
+       -I$(top_srcdir)/extensions                      \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DGCR_API_SUBJECT_TO_CHANGE                     \
@@ -28,10 +29,6 @@ BUILT_SOURCES =                                      \
 libempathy_gtk_handwritten_source =                    \
        empathy-account-chooser.c               \
        empathy-account-selector-dialog.c               \
-       empathy-account-widget-irc.c            \
-       empathy-account-widget-private.h        \
-       empathy-account-widget-sip.c            \
-       empathy-account-widget.c                \
        empathy-avatar-chooser.c                \
        empathy-avatar-image.c                  \
        empathy-bad-password-dialog.c           \
@@ -62,9 +59,6 @@ libempathy_gtk_handwritten_source =                   \
        empathy-individual-view.c               \
        empathy-individual-widget.c             \
        empathy-input-text-view.c               \
-       empathy-irc-network-chooser.c \
-       empathy-irc-network-chooser-dialog.c \
-       empathy-irc-network-dialog.c            \
        empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
        empathy-new-account-dialog.c            \
@@ -100,9 +94,6 @@ libempathy_gtk_handwritten_source =                  \
 libempathy_gtk_headers =                       \
        empathy-account-chooser.h               \
        empathy-account-selector-dialog.h               \
-       empathy-account-widget-irc.h            \
-       empathy-account-widget-sip.h            \
-       empathy-account-widget.h                \
        empathy-avatar-chooser.h                \
        empathy-avatar-image.h                  \
        empathy-bad-password-dialog.h           \
@@ -134,9 +125,6 @@ libempathy_gtk_headers =                    \
        empathy-individual-view.h               \
        empathy-individual-widget.h             \
        empathy-input-text-view.h               \
-       empathy-irc-network-chooser.h \
-       empathy-irc-network-chooser-dialog.h \
-       empathy-irc-network-dialog.h            \
        empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
        empathy-new-account-dialog.h            \
@@ -181,7 +169,7 @@ libempathy_gtk_la_LDFLAGS = \
 libempathy_gtk_la_SOURCES =                    \
        $(libempathy_gtk_handwritten_source)    \
        $(libempathy_gtk_headers)               \
-       totem-subtitle-encoding.c totem-subtitle-encoding.h
+       $(NULL)
 
 # do not distribute generated files
 nodist_libempathy_gtk_la_SOURCES =\
@@ -200,6 +188,7 @@ libempathy_gtk_la_LIBADD =                  \
        $(GCR_LIBS)                             \
        $(MEEGO_LIBS)                           \
        $(CHEESE_LIBS)                          \
+       $(top_builddir)/tp-account-widgets/libtp-account-widgets.la \
        $(top_builddir)/libempathy-gtk/egg-list-box/libegglistbox.la \
        $(top_builddir)/libempathy/libempathy.la
 
@@ -209,10 +198,7 @@ check_c_sources = \
 include $(top_srcdir)/tools/check-coding-style.mk
 check-local: check-coding-style
 
-uidir = $(datadir)/empathy
-ui_DATA =                                      \
-       empathy-contact-widget.ui               \
-       empathy-contact-blocking-dialog.ui      \
+account_widgets_ui_files =                     \
        empathy-account-widget-generic.ui       \
        empathy-account-widget-jabber.ui        \
        empathy-account-widget-msn.ui           \
@@ -223,6 +209,12 @@ ui_DATA =                                  \
        empathy-account-widget-yahoo.ui         \
        empathy-account-widget-groupwise.ui     \
        empathy-account-widget-aim.ui           \
+       $(NULL)
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-contact-widget.ui               \
+       empathy-contact-blocking-dialog.ui      \
        empathy-status-preset-dialog.ui         \
        empathy-log-window.ui                   \
        empathy-chat.ui                         \
@@ -240,7 +232,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
                        --fhead "G_BEGIN_DECLS\n\n" \
                        --ftail "G_END_DECLS\n\n" \
                        --ftail "#endif /* __LIBEMPATHY_GTK_ENUM_TYPES_H__ */\n" \
-                       --fprod "#include <libempathy-gtk/@filename@>\n" \
+                       --fprod '#include "@filename@"\n' \
                        --eprod "#define EMPATHY_TYPE_@ENUMSHORT@ @enum_name@_get_type()\n" \
                        --eprod "GType @enum_name@_get_type (void);\n" \
                $(libempathy_gtk_headers) ) > xgen-gth \
@@ -267,7 +259,7 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-EXTRA_DIST =                   \
+EXTRA_DIST =                                   \
        $(ui_DATA)
 
 if HAVE_GEOCLUE