]> git.0d.be Git - empathy.git/blobdiff - libempathy-gtk/Makefile.am
add empathy-local-xmpp-assistant-widget
[empathy.git] / libempathy-gtk / Makefile.am
index 494e3c4ce8e6978469c7ce676194b8f2045322db..c32448fa52f6faefed0e449eb209aeef36c4a0a9 100644 (file)
+include $(top_srcdir)/tools/flymake.mk
+
 AM_CPPFLAGS =                                           \
+       $(ERROR_CFLAGS)                                 \
        -I.                                             \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       -DGCR_API_SUBJECT_TO_CHANGE                     \
        $(EMPATHY_CFLAGS)                               \
-       $(WARN_CFLAGS)
+       $(YELL_CFLAGS)                                  \
+       $(ENCHANT_CFLAGS)                               \
+       $(LIBCHAMPLAIN_CFLAGS)                          \
+       $(GEOCLUE_CFLAGS)                               \
+       $(GEOCODE_CFLAGS)                               \
+       $(MEEGO_CFLAGS)                                 \
+       $(CHEESE_CFLAGS)                                \
+       $(EDS_CFLAGS)                                   \
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 BUILT_SOURCES =                                        \
        empathy-gtk-enum-types.h                        \
        empathy-gtk-enum-types.c
 
-lib_LTLIBRARIES = libempathy-gtk.la
+noinst_LTLIBRARIES = libempathy-gtk.la
 
-libempathy_gtk_la_SOURCES =                    \
-       ephy-spinner.c ephy-spinner.h           \
-       empathy-main-window.c                   \
-       empathy-status-icon.c                   \
-       empathy-contact-widget.c                \
-       empathy-contact-dialogs.c               \
-       empathy-accounts-dialog.c               \
-       empathy-account-widget-generic.c        \
-       empathy-account-widget-jabber.c         \
-       empathy-account-widget-msn.c            \
-       empathy-account-widget-salut.c          \
-       empathy-profile-chooser.c               \
+libempathy_gtk_handwritten_source =                    \
+       empathy-account-chooser.c               \
+       empathy-account-selector-dialog.c               \
+       empathy-account-widget-irc.c            \
+       empathy-account-widget-private.h        \
+       empathy-account-widget-sip.c            \
+       empathy-account-widget.c                \
+       empathy-avatar-chooser.c                \
+       empathy-avatar-image.c                  \
+       empathy-bad-password-dialog.c           \
+       empathy-base-password-dialog.c          \
+       empathy-call-utils.c                    \
+       empathy-cell-renderer-activatable.c     \
        empathy-cell-renderer-expander.c        \
        empathy-cell-renderer-text.c            \
-       empathy-cell-renderer-activatable.c     \
-       empathy-spell.c                         \
-       empathy-spell-dialog.c                  \
-       empathy-contact-groups.c                \
-       empathy-contact-list-store.c            \
-       empathy-contact-list-view.c             \
-       empathy-preferences.c                   \
-       empathy-theme.c                                 \
-       empathy-theme-boxes.c                   \
-       empathy-theme-irc.c                             \
-       empathy-theme-manager.c                 \
-       empathy-theme-utils.c                   \
-       empathy-smiley-manager.c                \
-       empathy-chat-window.c                   \
-       empathy-chat.c                          \
+       empathy-chat-text-view.c                \
        empathy-chat-view.c                     \
-       empathy-private-chat.c                  \
-       empathy-group-chat.c                    \
+       empathy-chat.c                          \
+       empathy-contact-blocking-dialog.c       \
+       empathy-contact-dialogs.c               \
+       empathy-contact-chooser.c               \
+       empathy-contactinfo-utils.c             \
+       empathy-live-search.c                   \
+       empathy-contact-search-dialog.c         \
+       empathy-contact-widget.c                \
+       empathy-dialpad-widget.c                \
        empathy-geometry.c                      \
-       empathy-status-presets.c                \
-       empathy-presence-chooser.c              \
-       empathy-about-dialog.c                  \
-       empathy-account-chooser.c               \
-       empathy-new-chatroom-dialog.c           \
-       empathy-chatrooms-window.c              \
+       empathy-groups-widget.c                 \
+       empathy-individual-dialogs.c            \
+       empathy-individual-edit-dialog.c        \
+       empathy-individual-menu.c               \
+       empathy-individual-store.c              \
+       empathy-individual-store-channel.c              \
+       empathy-individual-store-manager.c              \
+       empathy-individual-view.c               \
+       empathy-individual-widget.c             \
+       empathy-input-text-view.c               \
+       empathy-irc-network-chooser.c \
+       empathy-irc-network-chooser-dialog.c \
+       empathy-irc-network-dialog.c            \
+       empathy-local-xmpp-assistant-widget.c \
        empathy-log-window.c                    \
-       empathy-call-window.c                   \
-       empathy-avatar-chooser.c                \
-       empathy-avatar-image.c                  \
+       empathy-new-account-dialog.c            \
+       empathy-new-message-dialog.c            \
+       empathy-new-call-dialog.c               \
+       empathy-notify-manager.c                \
+       empathy-password-dialog.c               \
+       empathy-presence-chooser.c              \
+       empathy-protocol-chooser.c              \
+       empathy-search-bar.c                    \
+       empathy-share-my-desktop.c              \
+       empathy-smiley-manager.c                \
+       empathy-sound-manager.c                 \
+       empathy-spell.c                         \
+       empathy-status-preset-dialog.c          \
+       empathy-string-parser.c                 \
+       empathy-theme-boxes.c                   \
+       empathy-theme-irc.c                     \
+       empathy-theme-manager.c                 \
+       empathy-tls-dialog.c                    \
        empathy-ui-utils.c                      \
-       empathy-new-message-dialog.c
-
-# do not distribute generated files
-nodist_libempathy_gtk_la_SOURCES =\
-       $(BUILT_SOURCES)
-
-libempathy_gtk_la_LIBADD =                     \
-       $(EMPATHY_LIBS)                         \
-       $(top_builddir)/libempathy/libempathy.la
-
-libempathy_gtk_la_LDFLAGS =                \
-       -version-info ${LIBEMPATHY_GTK_CURRENT}:${LIBEMPATHY_GTK_REVISION}:${LIBEMPATHY_GTK_AGE}
+       empathy-plist.c                         \
+       empathy-theme-adium.c                   \
+       empathy-webkit-utils.c                  \
+       $(NULL)
 
 libempathy_gtk_headers =                       \
-       empathy-images.h                        \
-       empathy-main-window.h                   \
-       empathy-status-icon.h                   \
-       empathy-contact-widget.h                \
-       empathy-contact-dialogs.h               \
-       empathy-accounts-dialog.h               \
-       empathy-account-widget-generic.h        \
-       empathy-account-widget-jabber.h         \
-       empathy-account-widget-msn.h            \
-       empathy-account-widget-salut.h          \
-       empathy-profile-chooser.h               \
+       empathy-account-chooser.h               \
+       empathy-account-selector-dialog.h               \
+       empathy-account-widget-irc.h            \
+       empathy-account-widget-sip.h            \
+       empathy-account-widget.h                \
+       empathy-avatar-chooser.h                \
+       empathy-avatar-image.h                  \
+       empathy-bad-password-dialog.h           \
+       empathy-base-password-dialog.h          \
+       empathy-call-utils.h                    \
+       empathy-cell-renderer-activatable.h     \
        empathy-cell-renderer-expander.h        \
        empathy-cell-renderer-text.h            \
-       empathy-cell-renderer-activatable.h     \
-       empathy-spell.h                         \
-       empathy-spell-dialog.h                  \
-       empathy-contact-groups.h                \
-       empathy-contact-list-store.h            \
-       empathy-contact-list-view.h             \
-       empathy-preferences.h                   \
-       empathy-theme.h                                 \
-       empathy-theme-boxes.h                   \
-       empathy-theme-irc.h                             \
-       empathy-theme-manager.h                 \
-       empathy-theme-utils.h                   \
-       empathy-smiley-manager.h                \
-       empathy-chat-window.h                   \
-       empathy-chat.h                          \
+       empathy-chat-text-view.h                \
        empathy-chat-view.h                     \
-       empathy-private-chat.h                  \
-       empathy-group-chat.h                    \
+       empathy-chat.h                          \
+       empathy-contact-blocking-dialog.h       \
+       empathy-contact-dialogs.h               \
+       empathy-contact-chooser.h               \
+       empathy-live-search.h                   \
+       empathy-contact-search-dialog.h         \
+       empathy-contact-widget.h                \
+       empathy-contactinfo-utils.h             \
+       empathy-dialpad-widget.h                \
        empathy-geometry.h                      \
-       empathy-status-presets.h                \
-       empathy-presence-chooser.h              \
-       empathy-about-dialog.h                  \
-       empathy-account-chooser.h               \
-       empathy-new-chatroom-dialog.h           \
-       empathy-chatrooms-window.h              \
+       empathy-groups-widget.h                 \
+       empathy-images.h                        \
+       empathy-individual-dialogs.h            \
+       empathy-individual-edit-dialog.h        \
+       empathy-individual-menu.h               \
+       empathy-individual-store.h              \
+       empathy-individual-store-channel.h              \
+       empathy-individual-store-manager.h              \
+       empathy-individual-view.h               \
+       empathy-individual-widget.h             \
+       empathy-input-text-view.h               \
+       empathy-irc-network-chooser.h \
+       empathy-irc-network-chooser-dialog.h \
+       empathy-irc-network-dialog.h            \
+       empathy-local-xmpp-assistant-widget.h \
        empathy-log-window.h                    \
-       empathy-call-window.h                   \
-       empathy-avatar-chooser.h                \
-       empathy-avatar-image.h                  \
+       empathy-new-account-dialog.h            \
+       empathy-new-message-dialog.h            \
+       empathy-new-call-dialog.h               \
+       empathy-notify-manager.h                \
+       empathy-password-dialog.h               \
+       empathy-presence-chooser.h              \
+       empathy-protocol-chooser.h              \
+       empathy-search-bar.h                    \
+       empathy-share-my-desktop.h              \
+       empathy-smiley-manager.h                \
+       empathy-sound-manager.h                 \
+       empathy-spell.h                         \
+       empathy-status-preset-dialog.h          \
+       empathy-string-parser.h                 \
+       empathy-theme-boxes.h                   \
+       empathy-theme-irc.h                     \
+       empathy-theme-manager.h                 \
+       empathy-tls-dialog.h                    \
        empathy-ui-utils.h                      \
-       empathy-new-message-dialog.h
+       empathy-plist.h                         \
+       empathy-theme-adium.h                   \
+       empathy-webkit-utils.h                  \
+       $(NULL)
 
-libempathy_gtk_includedir = $(includedir)/libempathy-gtk/
-libempathy_gtk_include_HEADERS =               \
+
+libempathy_gtk_la_SOURCES =                    \
+       $(libempathy_gtk_handwritten_source)    \
        $(libempathy_gtk_headers)               \
-       empathy-gtk-enum-types.h
-
-gladedir = $(datadir)/empathy
-glade_DATA =                                   \
-       empathy-main-window.glade               \
-       empathy-status-icon.glade               \
-       empathy-contact-widget.glade            \
-       empathy-contact-dialogs.glade           \
-       empathy-preferences.glade               \
-       empathy-presence-chooser.glade          \
-       empathy-accounts-dialog.glade           \
-       empathy-account-widget-jabber.glade     \
-       empathy-account-widget-msn.glade        \
-       empathy-account-widget-salut.glade      \
-       empathy-new-chatroom-dialog.glade       \
-       empathy-group-chat.glade                \
-       empathy-chatrooms-window.glade          \
-       empathy-spell-dialog.glade              \
-       empathy-log-window.glade                \
-       empathy-call-window.glade               \
-       empathy-chat.glade                      \
-       empathy-new-message-dialog.glade
+       totem-subtitle-encoding.c totem-subtitle-encoding.h
+
+# do not distribute generated files
+nodist_libempathy_gtk_la_SOURCES =\
+       $(BUILT_SOURCES)
+
+libempathy_gtk_la_LIBADD =                     \
+       $(EMPATHY_LIBS)                 \
+       $(EMPATHY_LIBS)                 \
+       $(GTK_LIBS)                     \
+       $(LIBNOTIFY_LIBS)                       \
+       $(CANBERRA_LIBS) \
+       $(ENCHANT_LIBS)                         \
+       $(LIBCHAMPLAIN_LIBS)                    \
+       $(GEOCLUE_LIBS)                         \
+       $(GEOCODE_LIBS)                         \
+       $(GCR_LIBS)                             \
+       $(MEEGO_LIBS)                           \
+       $(CHEESE_LIBS)                          \
+       $(EDS_LIBS)                                     \
+       $(top_builddir)/libempathy/libempathy.la
+
+check_c_sources = \
+    $(libempathy_gtk_handwritten_source) \
+    $(libempathy_gtk_headers)
+include $(top_srcdir)/tools/check-coding-style.mk
+check-local: check-coding-style
+
+uidir = $(datadir)/empathy
+ui_DATA =                                      \
+       empathy-contact-widget.ui               \
+       empathy-contact-dialogs.ui              \
+       empathy-contact-blocking-dialog.ui      \
+       empathy-account-widget-generic.ui       \
+       empathy-account-widget-jabber.ui        \
+       empathy-account-widget-msn.ui           \
+       empathy-account-widget-sip.ui           \
+       empathy-account-widget-local-xmpp.ui    \
+       empathy-account-widget-irc.ui           \
+       empathy-account-widget-icq.ui           \
+       empathy-account-widget-yahoo.ui         \
+       empathy-account-widget-groupwise.ui     \
+       empathy-account-widget-aim.ui           \
+       empathy-status-preset-dialog.ui         \
+       empathy-log-window.ui                   \
+       empathy-chat.ui                         \
+       empathy-search-bar.ui                   \
+       empathy-individual-widget.ui
 
 empathy-gtk-enum-types.h: stamp-empathy-gtk-enum-types.h
-       @true
+       $(AM_V_GEN)true
 stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
-       (cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#ifndef __LIBEMPATHY_GTK_ENUM_TYPES_H__\n" \
                        --fhead "#define __LIBEMPATHY_GTK_ENUM_TYPES_H__ 1\n\n" \
@@ -160,7 +230,7 @@ stamp-empathy-gtk-enum-types.h: Makefile $(libempathy_gtk_headers)
        && echo timestamp > $(@F)
 
 empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
-       (cd $(srcdir) \
+       $(AM_V_GEN)(cd $(srcdir) \
        && glib-mkenums \
                        --fhead "#include <config.h>\n" \
                        --fhead "#include <glib-object.h>\n" \
@@ -178,17 +248,20 @@ empathy-gtk-enum-types.c: Makefile $(libempathy_gtk_headers)
        && cp xgen-gtc $(@F) \
        && rm -f xgen-gtc
 
-dtddir = $(datadir)/empathy
-dtd_DATA =                                     \
-       empathy-status-presets.dtd              \
-       empathy-contact-groups.dtd
+EXTRA_DIST =                   \
+       $(ui_DATA)
 
-pkgconfigdir = $(libdir)/pkgconfig
-pkgconfig_DATA = libempathy-gtk.pc
+if HAVE_GEOCLUE
+libempathy_gtk_handwritten_source +=           \
+       empathy-location-manager.c
 
-EXTRA_DIST =                   \
-       $(glade_DATA)           \
-       $(dtd_DATA)
+libempathy_gtk_headers +=                      \
+       empathy-location-manager.h
+else
+EXTRA_DIST +=                                  \
+       empathy-location-manager.c              \
+       empathy-location-manager.h
+endif
 
 CLEANFILES =                           \
        $(BUILT_SOURCES)                \