]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
Rename icons to follow fd.o icon naming spec. Move icons to the right
[empathy.git] / data / Makefile.am
index a39621f35e3ef69a178d02abac7743f7a94130c8..87566981abc4880387c7f494044a7445fd41cf44 100644 (file)
@@ -1,26 +1,16 @@
-SUBDIRS = 16x16
+SUBDIRS = icons
 
 profiledir = $(datadir)/mission-control/profiles
 profile_DATA =                                 \
        jabber.profile                  \
        gtalk.profile                   \
        salut.profile                   \
-       msn.profile
+       irc.profile                     \
+       msn.profile                     \
+       sofiasip.profile                \
+       aim.profile
 
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
-update-icon-cache:
-       @-if test -z "$(DESTDIR)"; then \
-               echo "Updating Gtk icon cache."; \
-               $(gtk_update_icon_cache); \
-       else \
-               echo "*** Icon cache not updated.  After (un)install, run this:"; \
-               echo "***   $(gtk_update_icon_cache)"; \
-       fi
-
-autostartdir = $(datadir)/gnome/autostart
+autostartdir = $(sysconfdir)/xdg/autostart
 autostart_in_files = empathy.desktop.in
 autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
 @INTLTOOL_DESKTOP_RULE@
@@ -42,12 +32,13 @@ install-data-local:
 endif
 
 EXTRA_DIST =                           \
-       $(image_DATA)                   \
-       $(autostart_DATA)               \
        $(profile_DATA)                 \
+       $(autostart_in_files)           \
+       $(autostart_DATA)               \
        $(schemas_in_files)             \
        $(schemas_DATA)
 
-DISTCLEANFILES =               \
+DISTCLEANFILES =                       \
+       $(autostart_DATA)               \
        $(schemas_DATA)