]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
Fix 'make install' for some automake versions. Fixes #570357.
[empathy.git] / data / Makefile.am
index cddd3a39ba6eb0a2dc09eb54f845219047403586..48cc350ccddd90afd02ac42c04745dc450ebaf44 100644 (file)
@@ -1,29 +1,27 @@
-SUBDIRS = 16x16 22x22 24x24 32x32 48x48 scalable
+SUBDIRS = icons
 
 profiledir = $(datadir)/mission-control/profiles
 profile_DATA =                                 \
+       aim.profile                     \
+       icq.profile                     \
        jabber.profile                  \
-       gtalk.profile                   \
        salut.profile                   \
+       yahoo.profile                   \
+       gtalk.profile                   \
        irc.profile                     \
-       msn.profile
-
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
-update-icon-cache:
-       @-if test -z "$(DESTDIR)"; then \
-               echo "Updating Gtk icon cache."; \
-               $(gtk_update_icon_cache); \
-       else \
-               echo "*** Icon cache not updated.  After (un)install, run this:"; \
-               echo "***   $(gtk_update_icon_cache)"; \
-       fi
-
-autostartdir = $(datadir)/gnome/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+       msn.profile                     \
+       msn-haze.profile                \
+       sofiasip.profile                \
+       ekiga.profile                   \
+       fwd.profile                     \
+       sipphone.profile                \
+       groupwise.profile               \
+       gadugadu.profile                \
+       qq.profile
+
+desktopdir = $(datadir)/applications
+desktop_in_files = empathy.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
 @INTLTOOL_DESKTOP_RULE@
 
 schemasdir      = $(GCONF_SCHEMA_FILE_DIR)
@@ -35,7 +33,7 @@ if GCONF_SCHEMAS_INSTALL
 install-data-local:
        if test -z "$(DESTDIR)" ; then \
          for p in $(schemas_DATA) ; do \
-           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
+           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p ; \
          done \
        fi
 else
@@ -43,14 +41,13 @@ install-data-local:
 endif
 
 EXTRA_DIST =                           \
-       $(image_DATA)                   \
        $(profile_DATA)                 \
-       $(autostart_in_files)           \
-       $(autostart_DATA)               \
+       $(desktop_in_files)             \
+       $(desktop_DATA)         \
        $(schemas_in_files)             \
        $(schemas_DATA)
 
 DISTCLEANFILES =                       \
-       $(autostart_DATA)               \
+       $(desktop_DATA)         \
        $(schemas_DATA)