]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
Merge branch 'irc-dialog-579800'
[empathy.git] / data / Makefile.am
index c2118a794c6fc2e5ac1ee92d77186b1cc4d46a95..48cc350ccddd90afd02ac42c04745dc450ebaf44 100644 (file)
@@ -11,11 +11,17 @@ profile_DATA =                              \
        irc.profile                     \
        msn.profile                     \
        msn-haze.profile                \
-       sofiasip.profile
+       sofiasip.profile                \
+       ekiga.profile                   \
+       fwd.profile                     \
+       sipphone.profile                \
+       groupwise.profile               \
+       gadugadu.profile                \
+       qq.profile
 
-autostartdir = $(sysconfdir)/xdg/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+desktopdir = $(datadir)/applications
+desktop_in_files = empathy.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
 @INTLTOOL_DESKTOP_RULE@
 
 schemasdir      = $(GCONF_SCHEMA_FILE_DIR)
@@ -27,7 +33,7 @@ if GCONF_SCHEMAS_INSTALL
 install-data-local:
        if test -z "$(DESTDIR)" ; then \
          for p in $(schemas_DATA) ; do \
-           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
+           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p ; \
          done \
        fi
 else
@@ -36,12 +42,12 @@ endif
 
 EXTRA_DIST =                           \
        $(profile_DATA)                 \
-       $(autostart_in_files)           \
-       $(autostart_DATA)               \
+       $(desktop_in_files)             \
+       $(desktop_DATA)         \
        $(schemas_in_files)             \
        $(schemas_DATA)
 
 DISTCLEANFILES =                       \
-       $(autostart_DATA)               \
+       $(desktop_DATA)         \
        $(schemas_DATA)