]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
Merge back from master
[empathy.git] / data / Makefile.am
index eef6801316affffc362f7bb957a33a2a052e0b71..43c3bb66c530ac9c9fec6796034e205cbafde7a1 100644 (file)
@@ -1,24 +1,7 @@
 SUBDIRS = icons
 
-profiledir = $(datadir)/mission-control/profiles
-profile_DATA =                                 \
-       aim.profile                     \
-       icq.profile                     \
-       jabber.profile                  \
-       salut.profile                   \
-       yahoo.profile                   \
-       gtalk.profile                   \
-       irc.profile                     \
-       msn.profile                     \
-       msn-haze.profile                \
-       sofiasip.profile                \
-       ekiga.profile                   \
-       fwd.profile                     \
-       sipphone.profile                \
-       groupwise.profile
-
 desktopdir = $(datadir)/applications
-desktop_in_files = empathy.desktop.in empathy-properties.desktop.in
+desktop_in_files = empathy.desktop.in
 desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
 @INTLTOOL_DESKTOP_RULE@
 
@@ -27,23 +10,32 @@ schemas_in_files = empathy.schemas.in
 schemas_DATA    = $(schemas_in_files:.schemas.in=.schemas)
 @INTLTOOL_SCHEMAS_RULE@
 
+streamingprefsdir =  $(datadir)/empathy
+streamingprefs_DATA =          \
+       codec-preferences       \
+       element-properties
+
 if GCONF_SCHEMAS_INSTALL
 install-data-local:
        if test -z "$(DESTDIR)" ; then \
          for p in $(schemas_DATA) ; do \
-           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
+           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p ; \
          done \
        fi
 else
 install-data-local:
 endif
 
+htmldir = $(datadir)/empathy
+html_DATA = Template.html
+
 EXTRA_DIST =                           \
-       $(profile_DATA)                 \
        $(desktop_in_files)             \
-       $(desktop_DATA)         \
+       $(desktop_DATA)                 \
        $(schemas_in_files)             \
-       $(schemas_DATA)
+       $(schemas_DATA)                 \
+       $(streamingprefs_DATA)          \
+       $(html_DATA)
 
 DISTCLEANFILES =                       \
        $(desktop_DATA)         \