]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
Merge back from master
[empathy.git] / data / Makefile.am
index 0822f40ef22005ef7c127235c733925e46bc6a4b..43c3bb66c530ac9c9fec6796034e205cbafde7a1 100644 (file)
@@ -1,28 +1,8 @@
-SUBDIRS = 16x16 22x22 32x32 scalable
-
-profiledir = $(datadir)/mission-control/profiles
-profile_DATA =                                 \
-       jabber.profile                  \
-       gtalk.profile                   \
-       salut.profile                   \
-       msn.profile
-
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
-
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
-update-icon-cache:
-       @-if test -z "$(DESTDIR)"; then \
-               echo "Updating Gtk icon cache."; \
-               $(gtk_update_icon_cache); \
-       else \
-               echo "*** Icon cache not updated.  After (un)install, run this:"; \
-               echo "***   $(gtk_update_icon_cache)"; \
-       fi
+SUBDIRS = icons
 
-autostartdir = $(datadir)/gnome/autostart
-autostart_in_files = empathy.desktop.in
-autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
+desktopdir = $(datadir)/applications
+desktop_in_files = empathy.desktop.in
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
 @INTLTOOL_DESKTOP_RULE@
 
 schemasdir      = $(GCONF_SCHEMA_FILE_DIR)
@@ -30,24 +10,34 @@ schemas_in_files = empathy.schemas.in
 schemas_DATA    = $(schemas_in_files:.schemas.in=.schemas)
 @INTLTOOL_SCHEMAS_RULE@
 
+streamingprefsdir =  $(datadir)/empathy
+streamingprefs_DATA =          \
+       codec-preferences       \
+       element-properties
+
 if GCONF_SCHEMAS_INSTALL
 install-data-local:
        if test -z "$(DESTDIR)" ; then \
          for p in $(schemas_DATA) ; do \
-           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $(srcdir)/$$p ; \
+           GCONF_CONFIG_SOURCE=$(GCONF_SCHEMA_CONFIG_SOURCE) $(GCONFTOOL) --makefile-install-rule $$p ; \
          done \
        fi
 else
 install-data-local:
 endif
 
+htmldir = $(datadir)/empathy
+html_DATA = Template.html
+
 EXTRA_DIST =                           \
-       $(image_DATA)                   \
-       $(autostart_DATA)               \
-       $(profile_DATA)                 \
+       $(desktop_in_files)             \
+       $(desktop_DATA)                 \
        $(schemas_in_files)             \
-       $(schemas_DATA)
+       $(schemas_DATA)                 \
+       $(streamingprefs_DATA)          \
+       $(html_DATA)
 
-DISTCLEANFILES =               \
+DISTCLEANFILES =                       \
+       $(desktop_DATA)         \
        $(schemas_DATA)