]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
sort contacts by most recent event
[empathy.git] / data / Makefile.am
index 5819434a2d23b8bd2feafe4a6d926d893b9dcd17..14b8be7dcfa42d2af001a7d42ca843540c125a7e 100644 (file)
@@ -1,20 +1,22 @@
-SUBDIRS = icons
+SUBDIRS = icons themes
 
 desktopdir = $(datadir)/applications
 desktop_in_files = \
        empathy.desktop.in \
-       empathy-accounts.desktop.in \
        $(NULL)
 desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
 @INTLTOOL_DESKTOP_RULE@
 
-gsettings_files = \
-       org.gnome.Empathy.gschema.xml.in \
-       $(NULL)
-gsettings_SCHEMAS = $(gsettings_files:.xml.in=.xml)
-@INTLTOOL_XML_NOMERGE_RULE@
+gsettings_SCHEMAS = org.gnome.Empathy.gschema.xml
 @GSETTINGS_RULES@
 
+# We need to compile schemas at make time
+# to run from source tree
+gschemas.compiled: $(gsettings_SCHEMAS:.xml=.valid)
+       $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
+
+all-local: gschemas.compiled
+
 convertdir = $(datarootdir)/GConf/gsettings
 convert_DATA = \
        empathy.convert
@@ -53,7 +55,18 @@ html_DATA = \
        empathy-log-window.html \
        $(NULL)
 
+cssdir = $(datadir)/empathy
+css_DATA = \
+       empathy.css \
+       $(NULL)
+
+appdatadir = $(datadir)/appdata
+appdata_in_files = empathy.appdata.xml.in
+appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+@INTLTOOL_XML_RULE@
+
 EXTRA_DIST =                           \
+       $(appdata_in_files)             \
        $(convert_DATA)                 \
        $(desktop_in_files)             \
        $(desktop_DATA)                 \
@@ -61,12 +74,17 @@ EXTRA_DIST =                                \
        $(html_DATA)                    \
        $(clientfile_DATA)              \
        $(servicefile_in_files)         \
-       $(gsettings_files)              \
+       $(gsettings_SCHEMAS)            \
+       $(css_DATA)                     \
        $(NULL)
+CLEANFILES = \
+       $(appdata_DATA)
+
 
 DISTCLEANFILES =               \
        $(desktop_DATA)         \
        $(schemas_DATA)         \
        $(servicefile_DATA)     \
-       $(gsettings_SCHEMAS)    \
+       $(css_DATA)             \
+       gschemas.compiled       \
        $(NULL)