]> git.0d.be Git - empathy.git/blobdiff - data/Makefile.am
roster-window: fix crash if empathy_chatroom_manager_find() failed
[empathy.git] / data / Makefile.am
index 0f2e1b0744a324a31915b72baaa599b7a5b666f6..14b8be7dcfa42d2af001a7d42ca843540c125a7e 100644 (file)
@@ -1,27 +1,90 @@
-SUBDIRS = 16x16
+SUBDIRS = icons themes
 
-profiledir = $(datadir)/mission-control/profiles
-profile_DATA =                                 \
-       jabber.profile                  \
-       gtalk.profile                   \
-       salut.profile                   \
-       msn.profile
+desktopdir = $(datadir)/applications
+desktop_in_files = \
+       empathy.desktop.in \
+       $(NULL)
+desktop_DATA = $(desktop_in_files:.desktop.in=.desktop)
+@INTLTOOL_DESKTOP_RULE@
 
-gtk_update_icon_cache = gtk-update-icon-cache -f -t $(datadir)/icons/hicolor
+gsettings_SCHEMAS = org.gnome.Empathy.gschema.xml
+@GSETTINGS_RULES@
 
-install-data-hook: update-icon-cache
-uninstall-hook: update-icon-cache
-update-icon-cache:
-       @-if test -z "$(DESTDIR)"; then \
-               echo "Updating Gtk icon cache."; \
-               $(gtk_update_icon_cache); \
-       else \
-               echo "*** Icon cache not updated.  After (un)install, run this:"; \
-               echo "***   $(gtk_update_icon_cache)"; \
-       fi
+# We need to compile schemas at make time
+# to run from source tree
+gschemas.compiled: $(gsettings_SCHEMAS:.xml=.valid)
+       $(AM_V_GEN) $(GLIB_COMPILE_SCHEMAS) --targetdir=. .
 
-EXTRA_DIST =           \
-       $(image_DATA)   \
-       $(profile_DATA)
+all-local: gschemas.compiled
 
+convertdir = $(datarootdir)/GConf/gsettings
+convert_DATA = \
+       empathy.convert
 
+servicefiledir = $(datadir)/dbus-1/services
+servicefile_in_files = \
+       org.freedesktop.Telepathy.Client.Empathy.Chat.service.in \
+       org.freedesktop.Telepathy.Client.Empathy.Auth.service.in \
+       org.freedesktop.Telepathy.Client.Empathy.Call.service.in \
+       org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service.in
+
+servicefile_DATA = $(servicefile_in_files:.service.in=.service)
+
+org.freedesktop.Telepathy.Client.Empathy.Chat.service: org.freedesktop.Telepathy.Client.Empathy.Chat.service.in
+       $(AM_V_GEN)sed -e "s|[@]libexecdir[@]|$(libexecdir)|" $< > $@
+
+org.freedesktop.Telepathy.Client.Empathy.Auth.service: org.freedesktop.Telepathy.Client.Empathy.Auth.service.in
+       $(AM_V_GEN)sed -e "s|[@]libexecdir[@]|$(libexecdir)|" $< > $@
+
+org.freedesktop.Telepathy.Client.Empathy.Call.service: org.freedesktop.Telepathy.Client.Empathy.Call.service.in
+       $(AM_V_GEN)sed -e "s|[@]libexecdir[@]|$(libexecdir)|" $< > $@
+
+org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service: org.freedesktop.Telepathy.Client.Empathy.FileTransfer.service.in
+       $(AM_V_GEN)sed -e "s|[@]bindir[@]|$(bindir)|" $< > $@
+
+clientfiledir = $(datarootdir)/telepathy/clients
+clientfile_DATA = \
+       Empathy.Chat.client \
+       Empathy.Auth.client \
+       Empathy.Call.client \
+       Empathy.FileTransfer.client
+
+htmldir = $(datadir)/empathy
+html_DATA = \
+       Template.html \
+       empathy-log-window.html \
+       $(NULL)
+
+cssdir = $(datadir)/empathy
+css_DATA = \
+       empathy.css \
+       $(NULL)
+
+appdatadir = $(datadir)/appdata
+appdata_in_files = empathy.appdata.xml.in
+appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+@INTLTOOL_XML_RULE@
+
+EXTRA_DIST =                           \
+       $(appdata_in_files)             \
+       $(convert_DATA)                 \
+       $(desktop_in_files)             \
+       $(desktop_DATA)                 \
+       $(schemas_DATA)                 \
+       $(html_DATA)                    \
+       $(clientfile_DATA)              \
+       $(servicefile_in_files)         \
+       $(gsettings_SCHEMAS)            \
+       $(css_DATA)                     \
+       $(NULL)
+CLEANFILES = \
+       $(appdata_DATA)
+
+
+DISTCLEANFILES =               \
+       $(desktop_DATA)         \
+       $(schemas_DATA)         \
+       $(servicefile_DATA)     \
+       $(css_DATA)             \
+       gschemas.compiled       \
+       $(NULL)