Make a separated module set for libempathy-gtk/ and src/
authorXavier Claessens <xclaesse@gmail.com>
Thu, 16 Apr 2009 12:27:36 +0000 (12:27 +0000)
committerXavier Claessens <xclaesse@src.gnome.org>
Thu, 16 Apr 2009 12:27:36 +0000 (12:27 +0000)
From: Xavier Claessens <xclaesse@gmail.com>

svn path=/trunk/; revision=2838

configure.ac
libempathy-gtk/Makefile.am

index f0fcf820163ab95abc251281874d2f219a0d6a1a..a42b76b4753fbc8aaacb35069a86971c4637f77d 100644 (file)
@@ -35,6 +35,7 @@ MISSION_CONTROL_REQUIRED=4.61
 ENCHANT_REQUIRED=1.2.0
 ISO_CODES_REQUIRED=0.35
 LIBNOTIFY_REQUIRED=0.4.4
+LIBCANBERRA_GTK_REQUIRED=0.4
 
 # Uncomment that to build with deprecated symbols disabled
 #AC_DEFINE(G_DISABLE_DEPRECATED, [], [Disable deprecated GLib symbols])
@@ -89,30 +90,47 @@ PKG_CHECK_MODULES(LIBEMPATHY,
 [
    glib-2.0 >= $GLIB_REQUIRED
    gobject-2.0
+   gio-2.0 >= $GLIB_REQUIRED
+   gio-unix-2.0 >= $GLIB_REQUIRED
    libxml-2.0
    telepathy-glib >= $TELEPATHY_GLIB_REQUIRED
    libmissioncontrol >= $MISSION_CONTROL_REQUIRED
-   gio-2.0 >= $GLIB_REQUIRED
-   gio-unix-2.0 >= $GLIB_REQUIRED
    telepathy-farsight
 ])
 
-PKG_CHECK_MODULES(EMPATHY,
+PKG_CHECK_MODULES(LIBEMPATHYGTK,
 [
    glib-2.0 >= $GLIB_REQUIRED
    gobject-2.0
    gio-2.0 >= $GLIB_REQUIRED
    gconf-2.0 >= $GCONF_REQUIRED
+   x11
+   gtk+-2.0 >= $GTK_REQUIRED
+   libcanberra-gtk >= $LIBCANBERRA_GTK_REQUIRED
+   libglade-2.0 >= $LIBGLADE_REQUIRED
    telepathy-glib >= $TELEPATHY_GLIB_REQUIRED
    libmissioncontrol >= $MISSION_CONTROL_REQUIRED
-   gtk+-2.0 >= $GTK_REQUIRED
+   telepathy-farsight
+   gstreamer-0.10
+   gstreamer-interfaces-0.10
+])
+
+PKG_CHECK_MODULES(EMPATHY,
+[
+   glib-2.0 >= $GLIB_REQUIRED
+   gobject-2.0
+   gio-2.0 >= $GLIB_REQUIRED
+   gconf-2.0 >= $GCONF_REQUIRED
    x11
+   gtk+-2.0 >= $GTK_REQUIRED
+   libcanberra-gtk >= $LIBCANBERRA_GTK_REQUIRED
    libglade-2.0 >= $LIBGLADE_REQUIRED
    libebook-1.2
-   libcanberra-gtk >= 0.4
+   telepathy-glib >= $TELEPATHY_GLIB_REQUIRED
+   libmissioncontrol >= $MISSION_CONTROL_REQUIRED
+   telepathy-farsight
    gstreamer-0.10
    gstreamer-interfaces-0.10
-   telepathy-farsight
 ])
 
 PKG_CHECK_MODULES(LIBNOTIFY, libnotify >= $LIBNOTIFY_REQUIRED)
index 46d03167ead948aff53e861cb7565d96bba3a32c..c7b02310026429a0594e10ba77960c61edf20b0a 100644 (file)
@@ -3,7 +3,7 @@ AM_CPPFLAGS =                                           \
        -I$(top_srcdir)                                 \
        -DDATADIR=\""$(datadir)"\"                      \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
-       $(EMPATHY_CFLAGS)                               \
+       $(LIBEMPATHYGTK_CFLAGS)                         \
        $(ENCHANT_CFLAGS)                               \
        $(WARN_CFLAGS)
 
@@ -60,7 +60,7 @@ nodist_libempathy_gtk_la_SOURCES =\
        $(BUILT_SOURCES)
 
 libempathy_gtk_la_LIBADD =                     \
-       $(EMPATHY_LIBS)                         \
+       $(LIBEMPATHYGTK_LIBS)                   \
        $(ENCHANT_LIBS)                         \
        $(top_builddir)/libempathy/libempathy.la