]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Fix build of tests
[empathy.git] / tests / Makefile.am
index 8c6094c959a1dead97463c573217dadc84bbe836..f823d4def1abe5d7186d9db8d9249986fe3b74a0 100644 (file)
@@ -1,3 +1,9 @@
+CLEANFILES=
+
+include $(top_srcdir)/rules/check.mak
+
+SUPPRESSIONS=valgrind.supp dlopen.supp
+
 AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
        $(EMPATHY_CFLAGS)                               \
@@ -13,3 +19,22 @@ bin_PROGRAMS =                       \
 
 contact_manager_SOURCES = contact-manager.c
 
+check_PROGRAMS = check-main
+TESTS = check-main
+check_main_SOURCES =                             \
+    check-main.c                                 \
+    check-helpers.c                              \
+    check-helpers.h                              \
+    check-libempathy.h                           \
+    check-empathy-utils.c
+
+check_main_LDADD = \
+    @CHECK_LIBS@ \
+    $(top_builddir)/libempathy-gtk/libempathy-gtk.la   \
+    $(top_builddir)/libempathy/libempathy.la           \
+    $(AM_LDFLAGS)
+
+check_main_CFLAGS = \
+    @CHECK_CFLAGS@ \
+    $(AM_CFLAGS)
+