]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Updated Polish translation
[empathy.git] / tests / Makefile.am
index 8ffdae72358ff15a86bae015884b6cd298bd1d71..9367615333a96ed992d17cafba24901a6e910bdf 100644 (file)
@@ -1,9 +1,7 @@
-SUBDIRS = xml
+SUBDIRS = interactive xml
 
 CLEANFILES=
 
-include $(top_srcdir)/rules/check.mak
-
 SUPPRESSIONS=valgrind.supp dlopen.supp
 
 EXTRA_DIST =           \
@@ -11,6 +9,7 @@ EXTRA_DIST =           \
        test.profile
 
 AM_CPPFLAGS =                                          \
+       $(ERROR_CFLAGS)                                 \
        -I$(top_srcdir)                                 \
        -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
@@ -22,59 +21,55 @@ LDADD =                                                             \
        $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
-noinst_PROGRAMS =                      \
-       contact-manager                 \
-       empetit                         \
-       test-empathy-account-assistant \
-       test-empathy-presence-chooser   \
-       test-empathy-status-preset-dialog \
-       test-empathy-protocol-chooser
-
-contact_manager_SOURCES = contact-manager.c
-empetit_SOURCES = empetit.c
-test_empathy_presence_chooser_SOURCES = test-empathy-presence-chooser.c
-test_empathy_status_preset_dialog_SOURCES = test-empathy-status-preset-dialog.c
-test_empathy_protocol_chooser_SOURCES = test-empathy-protocol-chooser.c
-test_empathy_account_assistant_SOURCES = test-empathy-account-assistant.c
-
-test_empathy_account_assistant_CFLAGS = -I$(top_srcdir)/src
-test_empathy_account_assistant_LDADD =                         \
-       $(top_builddir)/src/empathy-account-assistant.o \
-       $(LDADD)
-
-check_PROGRAMS = check-main
-TESTS = check-main
-check_main_SOURCES =                             \
-    check-main.c                                 \
-    check-helpers.c                              \
-    check-helpers.h                              \
-    check-libempathy.h                           \
-    check-empathy-utils.c                        \
-    check-empathy-helpers.h                      \
-    check-empathy-helpers.c                      \
-    check-irc-helper.h                           \
-    check-irc-helper.c                           \
-    check-empathy-irc-server.c                   \
-    check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c          \
-    check-empathy-chatroom.c                     \
-    check-empathy-chatroom-manager.c
-
-check_c_sources = \
-    $(check_main_SOURCES)
-include $(top_srcdir)/tools/check-coding-style.mk
-check-local: check-coding-style
-
-check_main_LDADD = \
-    @CHECK_LIBS@ \
-    $(top_builddir)/libempathy-gtk/libempathy-gtk.la   \
-    $(top_builddir)/libempathy/libempathy.la           \
-    $(AM_LDFLAGS)
-
-check_main_CFLAGS = \
-    @CHECK_CFLAGS@ \
-    $(AM_CFLAGS)
+TEST_PROGS =                                     \
+     empathy-utils-test                          \
+     empathy-irc-server-test                     \
+     empathy-irc-network-test                    \
+     empathy-irc-network-manager-test            \
+     empathy-chatroom-test                       \
+     empathy-chatroom-manager-test               \
+     empathy-parser-test
+
+empathy_utils_test_SOURCES = empathy-utils-test.c \
+     test-helper.c test-helper.h
+
+empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_test_SOURCES = empathy-irc-network-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_manager_test_SOURCES = empathy-irc-network-manager-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_chatroom_test_SOURCES = empathy-chatroom-test.c \
+     test-helper.c test-helper.h
+
+empathy_chatroom_manager_test_SOURCES = empathy-chatroom-manager-test.c \
+     test-helper.c test-helper.h
+
+empathy_parser_test_SOURCES = empathy-parser-test.c \
+     test-helper.c test-helper.h
+
+check_PROGRAMS = $(TEST_PROGS)
 
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \
                    MC_MANAGER_DIR=@abs_top_srcdir@/tests
+
+test-report: test-report.xml
+       gtester-report $(top_builddir)/tests/$@.xml > \
+         $(top_builddir)/tests/$@.html
+
+test-report.xml: ${TEST_PROGS} test
+
+test: ${TEST_PROGS}
+       gtester -o test-report.xml -k --verbose ${TEST_PROGS}
+
+test-%: empathy-%-test
+       gtester -o $@-report.xml -k --verbose $<
+
+.PHONY: test test-report