]> git.0d.be Git - empathy.git/blobdiff - tests/Makefile.am
Updated Polish translation
[empathy.git] / tests / Makefile.am
index 4e2654050500d37deece24c07d2a87268fd1973c..9367615333a96ed992d17cafba24901a6e910bdf 100644 (file)
@@ -1,58 +1,75 @@
-SUBDIRS = xml
+SUBDIRS = interactive xml
 
 CLEANFILES=
 
-include $(top_srcdir)/rules/check.mak
-
 SUPPRESSIONS=valgrind.supp dlopen.supp
 
+EXTRA_DIST =           \
+       test.manager    \
+       test.profile
+
 AM_CPPFLAGS =                                          \
+       $(ERROR_CFLAGS)                                 \
        -I$(top_srcdir)                                 \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        $(EMPATHY_CFLAGS)                               \
-       $(WARN_CFLAGS)
+       $(WARN_CFLAGS)                                  \
+       $(DISABLE_DEPRECATED)
 
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
-noinst_PROGRAMS =                      \
-       contact-manager                 \
-       contact-run-until-ready         \
-       contact-run-until-ready-2
-
-contact_manager_SOURCES = contact-manager.c
-contact_run_until_ready_SOURCES = contact-run-until-ready.c
-contact_run_until_ready_2_SOURCES = contact-run-until-ready-2.c
-
-check_PROGRAMS = check-main
-TESTS = check-main
-check_main_SOURCES =                             \
-    check-main.c                                 \
-    check-helpers.c                              \
-    check-helpers.h                              \
-    check-libempathy.h                           \
-    check-empathy-utils.c                        \
-    check-empathy-helpers.h                      \
-    check-empathy-helpers.c                      \
-    check-irc-helper.h                           \
-    check-irc-helper.c                           \
-    check-empathy-irc-server.c                   \
-    check-empathy-irc-network.c                  \
-    check-empathy-irc-network-manager.c          \
-    check-empathy-chatroom.c                     \
-    check-empathy-chatroom-manager.c
-
-check_main_LDADD = \
-    @CHECK_LIBS@ \
-    $(top_builddir)/libempathy-gtk/libempathy-gtk.la   \
-    $(top_builddir)/libempathy/libempathy.la           \
-    $(AM_LDFLAGS)
-
-check_main_CFLAGS = \
-    @CHECK_CFLAGS@ \
-    $(AM_CFLAGS)
+TEST_PROGS =                                     \
+     empathy-utils-test                          \
+     empathy-irc-server-test                     \
+     empathy-irc-network-test                    \
+     empathy-irc-network-manager-test            \
+     empathy-chatroom-test                       \
+     empathy-chatroom-manager-test               \
+     empathy-parser-test
+
+empathy_utils_test_SOURCES = empathy-utils-test.c \
+     test-helper.c test-helper.h
+
+empathy_irc_server_test_SOURCES = empathy-irc-server-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_test_SOURCES = empathy-irc-network-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_irc_network_manager_test_SOURCES = empathy-irc-network-manager-test.c \
+     test-helper.c test-helper.h                       \
+     test-irc-helper.h test-irc-helper.c
+
+empathy_chatroom_test_SOURCES = empathy-chatroom-test.c \
+     test-helper.c test-helper.h
+
+empathy_chatroom_manager_test_SOURCES = empathy-chatroom-manager-test.c \
+     test-helper.c test-helper.h
+
+empathy_parser_test_SOURCES = empathy-parser-test.c \
+     test-helper.c test-helper.h
+
+check_PROGRAMS = $(TEST_PROGS)
 
 TESTS_ENVIRONMENT = EMPATHY_SRCDIR=@abs_top_srcdir@ \
                    MC_PROFILE_DIR=@abs_top_srcdir@/tests \
                    MC_MANAGER_DIR=@abs_top_srcdir@/tests
+
+test-report: test-report.xml
+       gtester-report $(top_builddir)/tests/$@.xml > \
+         $(top_builddir)/tests/$@.html
+
+test-report.xml: ${TEST_PROGS} test
+
+test: ${TEST_PROGS}
+       gtester -o test-report.xml -k --verbose ${TEST_PROGS}
+
+test-%: empathy-%-test
+       gtester -o $@-report.xml -k --verbose $<
+
+.PHONY: test test-report