]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Move the event manager to src/
[empathy.git] / src / Makefile.am
index 4fe517debc024b40c3a8998aed6cef1418e7289a..d6dbc522a2904e81d4e58d79046e21d3b002f0bc 100644 (file)
@@ -1,20 +1,63 @@
-AM_CPPFLAGS =                                          \
+AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
        -DPREFIX="\"$(prefix)"\"                        \
        -DSYSCONFDIR=\""$(sysconfdir)"\"                \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DLIBDIR=\""$(libdir)"\"                        \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-bin_PROGRAMS = empathy
+LDADD =                                                                \
+       $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
+       $(top_builddir)/extensions/libemp-extensions.la         \
+       $(EMPATHY_LIBS)
 
-empathy_SOURCES =                                              \
-       empathy-main.c
+bin_PROGRAMS =                 \
+       empathy                 \
+       empathy-accounts        \
+       empathy-logs
 
-empathy_LDADD = \
-       $(top_builddir)/libempathy/libempathy.la                                \
-       $(top_builddir)/libempathy-gtk/libempathy-gtk.la                        \
-       $(EMPATHY_LIBS)
+empathy_SOURCES =                                                      \
+       empathy.c                                                       \
+       bacon-message-connection.c bacon-message-connection.h           \
+       ephy-spinner.c ephy-spinner.h                                   \
+       empathy-chat-window.c empathy-chat-window.h                     \
+       empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
+       empathy-status-icon.c empathy-status-icon.h                     \
+       empathy-about-dialog.c empathy-about-dialog.h                   \
+       empathy-chatrooms-window.c empathy-chatrooms-window.h           \
+       empathy-main-window.c empathy-main-window.h                     \
+       empathy-preferences.c empathy-preferences.h                     \
+       empathy-call-window.c empathy-call-window.h                     \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h             \
+       empathy-event-manager.c empathy-event-manager.h
+
+empathy_accounts_SOURCES = empathy-accounts.c                          \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h
+
+empathy_logs_SOURCES = empathy-logs.c
+
+gladedir = $(datadir)/empathy
+glade_DATA =                                   \
+       empathy-call-window.glade               \
+       empathy-main-window.glade               \
+       empathy-preferences.glade               \
+       empathy-chatrooms-window.glade          \
+       empathy-chat-window.glade               \
+       empathy-new-chatroom-dialog.glade       \
+       empathy-status-icon.glade               \
+       empathy-accounts-dialog.glade
+
+dist_man_MANS =                        \
+       empathy.1               \
+       empathy-accounts.1
+
+EXTRA_DIST =                   \
+       $(autostart_DATA)       \
+       $(glade_DATA)
 
+CLEANFILES = $(BUILT_SOURCES)