]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Move the event manager to src/
[empathy.git] / src / Makefile.am
index 133f7f5b52642621afa1ce8f4feb06dbb5291734..d6dbc522a2904e81d4e58d79046e21d3b002f0bc 100644 (file)
@@ -12,6 +12,7 @@ AM_CPPFLAGS =                                         \
 LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
        $(top_builddir)/libempathy/libempathy.la                \
+       $(top_builddir)/extensions/libemp-extensions.la         \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
@@ -22,6 +23,7 @@ bin_PROGRAMS =                        \
 empathy_SOURCES =                                                      \
        empathy.c                                                       \
        bacon-message-connection.c bacon-message-connection.h           \
+       ephy-spinner.c ephy-spinner.h                                   \
        empathy-chat-window.c empathy-chat-window.h                     \
        empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
        empathy-status-icon.c empathy-status-icon.h                     \
@@ -29,22 +31,14 @@ empathy_SOURCES =                                                   \
        empathy-chatrooms-window.c empathy-chatrooms-window.h           \
        empathy-main-window.c empathy-main-window.h                     \
        empathy-preferences.c empathy-preferences.h                     \
-       ephy-spinner.c ephy-spinner.h
+       empathy-call-window.c empathy-call-window.h                     \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h             \
+       empathy-event-manager.c empathy-event-manager.h
 
-empathy_accounts_SOURCES = empathy-accounts.c
-empathy_logs_SOURCES = empathy-logs.c
-
-# Dbus service files
-servicedir = $(datadir)/dbus-1/services
-service_DATA =                                                 \
-       org.gnome.Empathy.Chat.service
-
-%.service: %.service.in Makefile
-       @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< | sed -e "s|\@bindir\@|$(bindir)|" > $@
+empathy_accounts_SOURCES = empathy-accounts.c                          \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h
 
-chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA =                                                        \
-       empathy-chat.chandler
+empathy_logs_SOURCES = empathy-logs.c
 
 gladedir = $(datadir)/empathy
 glade_DATA =                                   \
@@ -54,28 +48,16 @@ glade_DATA =                                        \
        empathy-chatrooms-window.glade          \
        empathy-chat-window.glade               \
        empathy-new-chatroom-dialog.glade       \
-       empathy-status-icon.glade
+       empathy-status-icon.glade               \
+       empathy-accounts-dialog.glade
 
-BUILT_SOURCES =                                                        \
-       $(service_DATA)
+dist_man_MANS =                        \
+       empathy.1               \
+       empathy-accounts.1
 
-EXTRA_DIST =                                                   \
-       org.gnome.Empathy.Chat.service.in                       \
-       org.gnome.Empathy.Call.service.in                       \
-       $(autostart_DATA)                                       \
-       $(chandler_DATA)                                        \
+EXTRA_DIST =                   \
+       $(autostart_DATA)       \
        $(glade_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)
 
-if HAVE_VOIP
-libexec_PROGRAMS = empathy-call-chandler
-empathy_call_chandler_SOURCES =                                \
-       empathy-call-chandler.c                         \
-       empathy-call-window.c empathy-call-window.h
-service_DATA +=        org.gnome.Empathy.Call.service
-chandler_DATA += empathy-call.chandler
-else
-EXTRA_DIST += empathy-call.chandler
-endif
-