]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Move the event manager to src/
[empathy.git] / src / Makefile.am
index 0f0c2d0c081cefbdb32548e0e9ef504b2277eaf2..d6dbc522a2904e81d4e58d79046e21d3b002f0bc 100644 (file)
@@ -1,53 +1,63 @@
-cppflags =                     \
+AM_CPPFLAGS =                                          \
        -I$(top_srcdir)                                 \
        -DPREFIX="\"$(prefix)"\"                        \
        -DSYSCONFDIR=\""$(sysconfdir)"\"                \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DLIBDIR=\""$(libdir)"\"                        \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-libs =                                                         \
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
+       $(top_builddir)/extensions/libemp-extensions.la         \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
-       empathy-chat            \
-       empathy-accounts
-
-empathy_SOURCES = empathy-main.c
-empathy_CPPFLAGS = $(cppflags)
-empathy_LDADD = $(libs)
-
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cppflags)
-empathy_accounts_LDADD = $(libs)
-
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cppflags)
-empathy_chat_LDADD = $(libs)
-
-# Dbus service file
-servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
-
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
-       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
-
-chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
-
-BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service
-
-EXTRA_DIST =                                                   \
-       org.gnome.Empathy.Chat.service.in                       \
-       $(autostart_DATA)                                       \
-       $(chandler_DATA)
+       empathy-accounts        \
+       empathy-logs
+
+empathy_SOURCES =                                                      \
+       empathy.c                                                       \
+       bacon-message-connection.c bacon-message-connection.h           \
+       ephy-spinner.c ephy-spinner.h                                   \
+       empathy-chat-window.c empathy-chat-window.h                     \
+       empathy-new-chatroom-dialog.c empathy-new-chatroom-dialog.h     \
+       empathy-status-icon.c empathy-status-icon.h                     \
+       empathy-about-dialog.c empathy-about-dialog.h                   \
+       empathy-chatrooms-window.c empathy-chatrooms-window.h           \
+       empathy-main-window.c empathy-main-window.h                     \
+       empathy-preferences.c empathy-preferences.h                     \
+       empathy-call-window.c empathy-call-window.h                     \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h             \
+       empathy-event-manager.c empathy-event-manager.h
+
+empathy_accounts_SOURCES = empathy-accounts.c                          \
+       empathy-accounts-dialog.c empathy-accounts-dialog.h
+
+empathy_logs_SOURCES = empathy-logs.c
+
+gladedir = $(datadir)/empathy
+glade_DATA =                                   \
+       empathy-call-window.glade               \
+       empathy-main-window.glade               \
+       empathy-preferences.glade               \
+       empathy-chatrooms-window.glade          \
+       empathy-chat-window.glade               \
+       empathy-new-chatroom-dialog.glade       \
+       empathy-status-icon.glade               \
+       empathy-accounts-dialog.glade
+
+dist_man_MANS =                        \
+       empathy.1               \
+       empathy-accounts.1
+
+EXTRA_DIST =                   \
+       $(autostart_DATA)       \
+       $(glade_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)