]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
use a single window, with tabs
[empathy.git] / src / Makefile.am
index 0766d95807dc857c32349c004c1800cba10dd9f7..c792dd51e68ab4f54185b5b432f2df69fc9025ee 100644 (file)
@@ -2,6 +2,7 @@ include $(top_srcdir)/tools/flymake.mk
 
 CPPFLAGS_COMMON =                                      \
        $(EMPATHY_CFLAGS)                               \
+       $(TPAW_CFLAGS)                                  \
        $(ERROR_CFLAGS)                                 \
        -I$(top_srcdir)/libempathy-gtk                  \
        -I$(top_srcdir)/libempathy                      \
@@ -27,6 +28,7 @@ LDADD =                                                               \
        $(top_builddir)/extensions/libemp-extensions.la         \
        $(GCR_LIBS)                                             \
        $(EMPATHY_LIBS)                                         \
+       $(TPAW_LIBS)                                            \
        $(LIBCHAMPLAIN_LIBS)                                    \
        $(UOA_LIBS)                                             \
        $(NULL)
@@ -56,8 +58,7 @@ bin_PROGRAMS =                        \
 
 libexec_PROGRAMS = \
        empathy-auth-client \
-       empathy-call \
-       empathy-chat
+       empathy-call
 
 empathy_accounts_SOURCES =                                             \
        empathy-accounts.c empathy-accounts.h                           \
@@ -84,11 +85,13 @@ empathy_auth_client_SOURCES =                                               \
        $(NULL)
 
 empathy_chat_SOURCES =                                         \
+       chat-manager-interface.c chat-manager-interface.h \
        empathy-about-dialog.c empathy-about-dialog.h                   \
        empathy-chat-manager.c empathy-chat-manager.h           \
        empathy-chat-window.c empathy-chat-window.h             \
        empathy-invite-participant-dialog.c empathy-invite-participant-dialog.h \
        empathy-chat.c \
+       polari-fixed-size-frame.c  polari-fixed-size-frame.h \
        $(NULL)
 
 nodist_empathy_chat_SOURCES = \
@@ -148,10 +151,12 @@ empathy_handwritten_source = \
        empathy-preferences.c empathy-preferences.h                     \
        empathy-status-icon.c empathy-status-icon.h                     \
        empathy-chat-manager.c empathy-chat-manager.h                   \
+       polari-fixed-size-frame.c  polari-fixed-size-frame.h \
        empathy.c
 
 empathy_SOURCES =                                                      \
        $(empathy_handwritten_source)                                   \
+       chat-manager-interface.c chat-manager-interface.h \
        $(NULL)
 
 empathy_LDADD =                                                                \
@@ -195,26 +200,33 @@ EXTRA_DIST =                      \
        $(autostart_DATA)       \
        $(ui_DATA)              \
        empathy-chat.js         \
-       empathy-chat.gresource.xml
+       empathy-chat.gresource.xml \
+       Chat_Manager.xml
 
 dist_man_MANS =                        \
        empathy.1 \
        empathy-accounts.1
 
+chat-manager-interface.c: chat-manager-interface.h
+chat-manager-interface.h: Makefile.am Chat_Manager.xml
+       gdbus-codegen \
+               --interface-prefix org.gnome.Empathy. \
+               --c-namespace EmpathyGen \
+               --generate-c-code chat-manager-interface \
+               Chat_Manager.xml
+
 BUILT_SOURCES = \
        $(nodist_empathy_chat_SOURCES) \
+       chat-manager-interface.c \
+       chat-manager-interface.h \
        $(NULL)
 
 CLEANFILES = $(BUILT_SOURCES)
 
-empathy-chat-resources.c: empathy-chat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies $(srcdir)/empathy-chat.gresource.xml)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ \
-               --sourcedir=$(srcdir) \
-               --generate-source \
-               $<
-
-empathy-chat-resources.h: empathy-chat.gresource.xml $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies $(srcdir)/empathy-chat.gresource.xml)
-       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ \
-               --sourcedir=$(srcdir) \
-               --generate-header \
-               $<
+chat_resource_files: $(shell $(GLIB_COMPILE_RESOURCES) --generate-dependencies --sourcedir=$(srcdir) $(srcdir)/empathy-chat.gresource.xml)
+
+empathy-chat-resources.c: empathy-chat.gresource.xml $(chat_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-source $<
+
+empathy-chat-resources.h: empathy-chat.gresource.xml $(chat_resource_files)
+       $(AM_V_GEN)$(GLIB_COMPILE_RESOURCES) --target=$@ --sourcedir=$(srcdir) --generate-header $<