]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
[darcs-to-svn @ Remove EmpathySession and move all programs into src/]
[empathy.git] / src / Makefile.am
index b9c9ca2e844eb22cd19a64157890e2f8a13b1fee..83b071790e6239702f3e44213ec2d6aed743c0e6 100644 (file)
@@ -1,23 +1,54 @@
-AM_CPPFLAGS =                                          \
-       -I$(top_srcdir)                                 \
-       -DPREFIX="\"$(prefix)"\"                        \
-       -DSYSCONFDIR=\""$(sysconfdir)"\"                \
-       -DDATADIR=\""$(datadir)"\"                      \
-       -DLIBDIR=\""$(libdir)"\"                        \
-       $(EMPATHY_CFLAGS)                               \
+AM_CPPFLAGS =                                                  \
+       -I$(top_srcdir)                                         \
+       -DPREFIX="\"$(prefix)"\"                                \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"                        \
+       -DDATADIR=\""$(datadir)"\"                              \
+       -DLIBDIR=\""$(libdir)"\"                                \
+       $(EMPATHY_CFLAGS)                                       \
        $(WARN_CFLAGS)
 
-bin_PROGRAMS = empathy
+LDADD =                                                                \
+       $(top_builddir)/libempathy/libempathy.la                \
+       $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(EMPATHY_LIBS)
 
-empathy_SOURCES =                                              \
+bin_PROGRAMS = empathy empathy-accounts empathy-chat empathy-contact-list
+empathy_SOURCES =                                              \
        empathy-main.c
 
-empathy_LDADD = \
-       $(top_builddir)/libempathy/libempathy.la                                \
-       $(top_builddir)/libempathy-gtk/libempathy-gtk.la                        \
-       $(EMPATHY_LIBS)
+empathy_accounts_SOURCES =                                     \
+       empathy-accounts-main.c
+
+empathy_chat_SOURCES =                                         \
+       empathy-chat-main.c
+
+empathy_contact_list_SOURCES =                                 \
+       empathy-contact-list-main.c
+
+# Dbus service file
+servicedir = $(datadir)/dbus-1/services
+service_in_files = org.gnome.Empathy.Chat.service.in
+service_DATA = $(service_in_files:.service.in=.service)
+
+# Rule to make the service file with bindir expanded
+$(service_DATA): $(service_in_files) Makefile
+       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+
+chandlerdir = $(datadir)/telepathy/managers
+chandler_DATA = empathy-chat.chandler
 
 autostartdir = $(datadir)/gnome/autostart
 autostart_in_files = empathy.desktop.in
 autostart_DATA = $(autostart_in_files:.desktop.in=.desktop)
 @INTLTOOL_DESKTOP_RULE@
+
+BUILT_SOURCES =                                                        \
+       org.gnome.Empathy.Chat.service
+
+EXTRA_DIST =                                                   \
+       org.gnome.Empathy.Chat.service.in                       \
+       $(autostart_DATA)                                       \
+       $(chandler_DATA)
+
+CLEANFILES = $(BUILT_SOURCES)
+