]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Fix typo in var name and don't link empathy-call-chandler on libemp-extensions.la...
[empathy.git] / src / Makefile.am
index b89a4218de0b89227dd921b1b19a34853bf19a40..59d6c5c1ffbeac7748e57ac79cf628de6fa31024 100644 (file)
@@ -3,41 +3,59 @@ AM_CPPFLAGS =                                         \
        -DPREFIX="\"$(prefix)"\"                        \
        -DSYSCONFDIR=\""$(sysconfdir)"\"                \
        -DDATADIR=\""$(datadir)"\"                      \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
        -DLIBDIR=\""$(libdir)"\"                        \
        -DLOCALEDIR=\""$(datadir)/locale"\"             \
        $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-LDADD =                                                        \
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
-       empathy-accounts
+       empathy-accounts        \
+       empathy-logs
+
+libexec_PROGRAMS =             \
+       empathy-chat-chandler
 
 empathy_SOURCES = empathy.c
 empathy_accounts_SOURCES = empathy-accounts.c
+empathy_logs_SOURCES = empathy-logs.c
+empathy_chat_chandler_SOURCES = empathy-chat-chandler.c
 
-# Dbus service file
+# Dbus service files
 servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
+service_DATA =                                                 \
+       org.gnome.Empathy.Chat.service
 
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
-       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+%.service: %.service.in Makefile
+       @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
 
 chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
+chandler_DATA =                                                        \
+       empathy-chat.chandler
 
 BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service
+       $(service_DATA)
 
 EXTRA_DIST =                                                   \
        org.gnome.Empathy.Chat.service.in                       \
+       org.gnome.Empathy.Call.service.in                       \
        $(autostart_DATA)                                       \
        $(chandler_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)
 
+if HAVE_VOIP
+libexec_PROGRAMS += empathy-call-chandler
+empathy_call_chandler_SOURCES = empathy-call-chandler.c
+service_DATA +=        org.gnome.Empathy.Call.service
+chandler_DATA += empathy-call.chandler
+else
+EXTRA_DIST += empathy-call.chandler
+endif
+