]> git.0d.be Git - empathy.git/blobdiff - src/Makefile.am
Fix typo in var name and don't link empathy-call-chandler on libemp-extensions.la...
[empathy.git] / src / Makefile.am
index 40f9e7d1e35ca388eabfaa03ad7621222436e87a..59d6c5c1ffbeac7748e57ac79cf628de6fa31024 100644 (file)
@@ -1,66 +1,61 @@
-cppflags =                     \
-       -I.                     \
-       -I$(top_srcdir)         \
-       $(EMPATHY_CFLAGS)       \
+AM_CPPFLAGS =                                          \
+       -I$(top_srcdir)                                 \
+       -DPREFIX="\"$(prefix)"\"                        \
+       -DSYSCONFDIR=\""$(sysconfdir)"\"                \
+       -DDATADIR=\""$(datadir)"\"                      \
+       -DPKGDATADIR=\""$(pkgdatadir)"\"                \
+       -DLIBDIR=\""$(libdir)"\"                        \
+       -DLOCALEDIR=\""$(datadir)/locale"\"             \
+       $(EMPATHY_CFLAGS)                               \
        $(WARN_CFLAGS)
 
-libs =                                                         \
+LDADD =                                                                \
        $(top_builddir)/libempathy-gtk/libempathy-gtk.la        \
+       $(top_builddir)/libempathy/libempathy.la                \
        $(EMPATHY_LIBS)
 
 bin_PROGRAMS =                 \
        empathy                 \
-       empathy-chat            \
-       empathy-accounts
+       empathy-accounts        \
+       empathy-logs
 
-empathy_SOURCES =                                              \
-       empathy-main.c                                          \
-       empathy-filter.c        empathy-filter.h
-empathy_CPPFLAGS = $(cppflags)
-empathy_LDADD = $(libs)
+libexec_PROGRAMS =             \
+       empathy-chat-chandler
 
-empathy_accounts_SOURCES = empathy-accounts-main.c
-empathy_accounts_CPPFLAGS = $(cppflags)
-empathy_accounts_LDADD = $(libs)
+empathy_SOURCES = empathy.c
+empathy_accounts_SOURCES = empathy-accounts.c
+empathy_logs_SOURCES = empathy-logs.c
+empathy_chat_chandler_SOURCES = empathy-chat-chandler.c
 
-empathy_chat_SOURCES = empathy-chat-main.c
-empathy_chat_CPPFLAGS = $(cppflags)
-empathy_chat_LDADD = $(libs)
-
-# MC plugin
-#pluginlib_LTLIBRARIES = libempathy-filter-plugin.la
-#libempathy_filter_plugin_la_SOURCES = empathy-filter-plugin.c
-#libempathy_filter_plugin_la_CPPFLAGS = $(MISSION_CONTROL_PLUGINS_CFLAGS)
-#libempathy_filter_plugin_la_LIBADD = $(MISSION_CONTROL_PLUGINS_LIBS)
-
-# Dbus service file
+# Dbus service files
 servicedir = $(datadir)/dbus-1/services
-service_in_files = org.gnome.Empathy.Chat.service.in
-service_DATA = $(service_in_files:.service.in=.service)
+service_DATA =                                                 \
+       org.gnome.Empathy.Chat.service
 
-# Rule to make the service file with bindir expanded
-$(service_DATA): $(service_in_files) Makefile
-       @sed -e "s|\@bindir\@|$(bindir)|" $< > $@
+%.service: %.service.in Makefile
+       @sed -e "s|\@libexecdir\@|$(libexecdir)|" $< > $@
 
 chandlerdir = $(datadir)/telepathy/managers
-chandler_DATA = empathy-chat.chandler
-
-# Empathy filter DBus API
-empathy-filter-glue.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-server --output=$@ $<
-empathy-filter-gen.h: empathy-filter.xml
-       $(LIBTOOL) --mode=execute $(DBUS_BINDING_TOOL) --prefix=empathy_filter --mode=glib-client --output=$@ $<
+chandler_DATA =                                                        \
+       empathy-chat.chandler
 
 BUILT_SOURCES =                                                        \
-       org.gnome.Empathy.Chat.service                          \
-       empathy-filter-glue.h                                   \
-       empathy-filter-gen.h
+       $(service_DATA)
 
 EXTRA_DIST =                                                   \
        org.gnome.Empathy.Chat.service.in                       \
-       empathy-filter.xml                                      \
+       org.gnome.Empathy.Call.service.in                       \
        $(autostart_DATA)                                       \
        $(chandler_DATA)
 
 CLEANFILES = $(BUILT_SOURCES)
 
+if HAVE_VOIP
+libexec_PROGRAMS += empathy-call-chandler
+empathy_call_chandler_SOURCES = empathy-call-chandler.c
+service_DATA +=        org.gnome.Empathy.Call.service
+chandler_DATA += empathy-call.chandler
+else
+EXTRA_DIST += empathy-call.chandler
+endif
+